3 Replies Latest reply on May 11, 2003 1:25 PM by Viet

    distrib module commited

    Viet Master

      I commited the distrib module.

      Basically it gathers others nukes modules within a single application.

      I updated security of all the modules. That's an important point. Also security declaration changes a little from the very unfriendly : 0:200:a:b:c:d:e:f to 0/200/a:b:c/d:e:f . Next step is to add identifier replacing 2--> by READ, etc.....

      I tried to express security rules at their minimum, with the less .* possible.

      The MenuBlock changed and now accept a name as constructor parameter so there can be more than one. I explain how security works for it :

      public boolean getDisplayed(Page page)
      {
      return getApi().secAuthAction(
      getName() + "::",
      "::",
      Constants.SEC_ACCESS_READ); }

      example : the rule 0/200/menu::/:: will enable display of the block.

      let's come to the main point :

      as I said before there is a distrib module, featuring : groups, sections, faq, html, journal, adminmessages, lostpassword, user, youraccount and of course core module.

      to build it :

      cd $nukes/build
      build -Dgroups=distrib

      that will create a nukes-distrib.ear in $nukes/distrib/output/lib.

      Now we have to work on the DB to make the release thr friendlier possible.

      julien

        • 1. Re: distrib module commited
          Yanik Crépeau Newbie

          I think I have missed something...

          I have desinstalled previous installation(s) of Nukes and its component. I drop the tables in the database.

          I have rebuild the set of tables using the various 'setup.ddl' in the sub-projects resources directories.

          I run the 'build -D groups=distrib and that created a file named nukes-distrib.ear.

          I copied the nukes-distrib.ear in the deploy directory of my jBoss engine.

          Deployment starts and I have a lot of Exceptions that could be summarized: (javax.naming.NameNotFoundException: NukesDS not bound)

          Could someone give me a quick fix for that problem?

          • 2. Re: distrib module commited
            Yanik Crépeau Newbie

            Found way to fix the problem described in the previous message:

            You have a file named nukes-ds.xml located uneder NUKES_DEV_DIR/nukes/output/resources/hsqldb/ or NUKES_DEV_DIR/nukes/output/resources/mysql/.

            Copy the file (nukes-ds.xml) in the deploy directory.

            Note: This should be done with the ant 'deploy' target.

            • 3. Re: distrib module commited
              Viet Master

              yes, it's written in another post

              we are no longer use DefaultDS. Always NukesDS so it makes things simpler. Hsqldb/NukesDS is just another instance of DefaultDS.

              So the thing that changes per db is the type mapping and the entity command name which is already abstracted by nukes-entity-command.

              julien