7 Replies Latest reply on Jun 23, 2003 7:42 AM by Viet

    How to deploy other modules?

    jkester Newbie

      Hello

      I notice that the nukes src project contains a lot of modules that are not automatically deployed when building and deploying nukes as mentioned in the tutorial.
      For instance from the jmx I only see available the following modules:
      nukes.modules

      * name=core
      * name=group
      * name=html
      * name=lostpassword
      * name=test
      * name=user
      * name=youraccount

      Now I wanted to deploy the journal module, and went to the journal subdir, and tried both with ant deploy as well, with build.sh deploy to get this module deployed.
      It does copy a nukes-journal.ear to the deploy directory, but fails the deployment with the message:

      status: Deployment FAILED reason: create operation failed for packag e file:/usr/local/jboss-3.2.2RC1/server/default/tmp/deploy/tmp15631nuk es-faq.ear-contents/nukes-faq.sar; - nested throwable: (javax.manageme nt.InstanceNotFoundException: nukes.modules:name=faq is not registered .)

      I checked the copied nukes-journal.ear file and it contains a META-INF, a *ejb.jar, *lib.jar and *.sar files/dirs.

      How should I deploy properly? What am I doing wrong?

      Regards, Jan.

        • 1. Re: How to deploy other modules?
          Viet Master

          I don't know, "sh build.sh deploy" should work.
          have you created db tables also ?

          also take care that nukes is already deployed.

          julien

          • 2. Re: How to deploy other modules?
            jkester Newbie

            Julien

            thanks. Indeed I added the setup.dll of the specific module :-). But that was still not the solution :-(.
            I found out from the jboss logs that the module-ear is read and it found two subpackages to deploy. Then, it looked at the *ejb.jar, and then at the *sar file. The sar file then went on for deployment and the first message before the "not registered" failure was a class not found for bean. The class was there, but in the *lib.jar file that had not been loaded yet :-(.

            So the whole problem seems to be in how jboss deploys, and the order of the *lib.jar, *ejb.jar and *sar file ...

            I did the test to load these three files separately, in the lib-ejb-sar order. That worked!

            How do other people deploy? Why am I the only one with this problem?

            Regards, Jan

            • 3. Re: How to deploy other modules?
              jkester Newbie

              Hello

              I think I found the answer. I noticed that some modules do deploy correctly and others not. Comparing them, I saw that for instance quotes and script (which deploy correctly), have a reference in their *ear/META-INF/application.xml configuration file to the lib jar, where as journal, adminmessages, faq and sections have not. The latter group therefore starts loading ejb and sar without having the lib loaded yet, thus fails.
              Could this be corrected in the source code?

              Regards, Jan

              • 4. Re: How to deploy other modules?
                Viet Master

                you should be done soon.

                thanks for help.

                julien

                • 5. done
                  Viet Master

                  this is corrected in CVS.

                  • 6. Re: How to deploy other modules?
                    jkester Newbie

                    Julien

                    they all work now, except the adminmessages. Same change needs to be applied there still.

                    Further I discovered that the build.sh of the news module is still in "dos" format. It didn't run. After applying a dos2unix command it does.
                    Could that one be changed as well?

                    Regards, Jan

                    • 7. Re: How to deploy other modules?
                      Viet Master

                      done