7 Replies Latest reply on Nov 5, 2003 8:49 PM by Steve Moyer

    Nukes Timecard Modue

    tbrockwell Newbie

      Hello.

      My wife and I run a small defense contracting company. I discovered JBoss/Nukes n my search for a CMS for our new company website, which is now in development.

      Our CMS must provide an online time tracking system, which will be used by our employees to charge their labor hours to various contracts, record paid time off, etc..

      Is anyone outhere interested in collaborating to create a Nukes Timecard block/module?

      Ultimately, I'd like to see this effort yield an open source alternative to the commercial cost accounting packages I've seen, which range in complexity and price from the simple and cheap (e.g. Quickbooks), to the VERY complex and VERY expensive (e.g. Deltek).

      For now, though, I'll settle for a simple Timecard module so that I can get my website up and running. ;-)

      Anyone interested?

      Thanks,
      T

        • 1. Re: Nukes Timecard Modue
          Viet Master

          My advice is : don't wait until someone pops up and help you because the probability it happens is very small. There are lot of talkers in open source software and few code something.

          If you want to do that module, just do it. If you need help and advice, I will do my best to help you.

          julien

          • 2. Re: Nukes Timecard Modue
            tbrockwell Newbie

            Thanks for the advice.

            Rest assured, I will "just do it". And, as the newest newbie to J2EE and JBoss, I will most assuredly require a lot of advice! ;-)

            T

            • 3. Re: Nukes Timecard Modue
              tbrockwell Newbie

              Hi Julien.

              Here is my first cry for help.

              Step 1 for me is to get my Win2K development host configured, so I need to get the JBoss IDE running within eclipse.

              I've created the Tutorial Fibonacci project using the eclipse IDE and JBoss 3.2.2RC4, and I'm getting a runtime error when I Debug or Run the JBoss server from within the IDE.

              The details of my installation and attempt to use the IDE are given below.

              Thanks much,
              T

              1. Installed JBoss on my Win 2K development host
              - Installed by unzipping jboss-3.2.2RC4.zip
              - Verified that JBoss runs

              2. Installed Eclipse Platform version 2.1.1, Build ID 200306271545

              3. Installed JBoss IDE Eclipse plugin by unzipping org.jboss.ide.eclipse_1.2.1.bin.dist.zip into Eclipse plugins directory

              4. In Eclipse/JBoss Server Navigator, created a new JBoss 3.2.x server configuration with the following parameters:

              - JBoss 3.x Home Directory = C:\Program Files\jboss-3.2.2RC4
              - Start - Program arguments =
              - VM arguments =
              - Shutdown - Program arguments = -S
              - VM arguments =
              - Log Files =
              - Classpath - User classes =
              - Bootstrap classes =

              (note: I also included jars from C:/j2sdk1.4.1_05/jre/lib, with the same results)

              C:/Program Files/Java/j2re1.4.1_05/lib/rt.jar
              C:/Program Files/Java/j2re1.4.1_05/lib/sunrsasign.jar.jar
              C:/Program Files/Java/j2re1.4.1_05/lib/jsse.jar
              C:/Program Files/Java/j2re1.4.1_05/lib/jce.jar
              C:/Program Files/Java/j2re1.4.1_05/lib/charsets.jar
              C:/Program Files/Java/j2re1.4.1_05/lib/ext/dnsns.jar
              C:/Program Files/Java/j2re1.4.1_05/lib/ext/ldapsec.jar
              C:/Program Files/Java/j2re1.4.1_05/lib/ext/localedata.jar
              C:/Program Files/Java/j2re1.4.1_05/lib/ext/sunjce_provider.jar

              - JDK - JRE type = Standard VM
              - JRE name = test2
              - JRE home directory = C:\j2sdk1.4.1_05
              - Javadoc URL = http://java.sun.com/j2se/1.4.1/docs/api
              - JRE system libraries =
              C:/j2sdk1.4.1_05/jre/lib/rt.jar C:/j2sdk1.4.1_05/jre/lib/sunrsasign.jar
              C:/j2sdk1.4.1_05/jre/lib/jsse.jar C:/j2sdk1.4.1_05/jre/lib/jce.jar
              C:/j2sdk1.4.1_05/jre/lib/charsets.jar C:/j2sdk1.4.1_05/jre/lib/ext/dnsns.jar
              C:/j2sdk1.4.1_05/jre/lib/ext/ldapsec.jar
              C:/j2sdk1.4.1_05/jre/lib/ext/localedata.jar C:/j2sdk1.4.1_05/jre/lib/ext/sunjce_provider.jar
              - Use default system libraries = checked (tried it both checked and unchecked)

              5. Created the Fibonacci J2EE Tutorial application according to the JBoss IDE 1.2.0 Tutorial (Tutorial_1.2.0.pdf)


              6 Problem: When I "Run" or "Debug" the JBoss 3.2.x server I created, I get the following pop up errors:
              - Could not find the main class. Program will exit!
              - org.eclipse.core.runtime.CoreException Cannot connect to VM

              The eclipse console contains the following messages:
              "java.lang.NoClassDefFoundError: Files\jboss-3/2/2RC4
              Exception in thread "main" "

              • 4. Re: Nukes Timecard Modue
                tbrockwell Newbie

                Hey Julien.

                Never mind. I found another post that helped me fix it.

                When I installed JBoss using the default installation directories, it was placed in C:\Program Files\...

                The IDE launcher crashes if there are spaces in the path to the JBoss server. Using single quotes, double quotes, environment vars, or file system shortcuts does not work.

                All I had to do was move the JBoss installation directory from C:\Program Files to C:\ and the problem was solved.

                Maybe you (JBoss.org development team) should change the default installation directory to C:\, to prevent others from having this same problem. Or maybe the IDE could be changed to allow for spaces in the path.

                Thanks,
                T

                • 5. Re: Nukes Timecard Modue
                  tbrockwell Newbie

                  Hi Julien.

                  2 questions:

                  1. Within the eclipse JBoss server configuration tool, how can I delete a JDK after I've created one for a JBoss server?

                  e.g. I configure a server with a new JDK named "test1". I delete the configuration.

                  I create a new server configuration and attempt to name the JDK "test1".

                  I get an error telling me that the JDK name is already in use.

                  I'm ending up with tons of JDKs! I'd like to delete them all and start from scratch.

                  Is there a configuration file that I can use to directly edit, rename or get rid of all these JDKs?

                  2. I need some advice on how to use the JBoss IDE to develop and deploy a Nukes module. Got any hints vis-a-vis project hierarchy, commonly used jars, development process etc. etc. ?

                  Thanks,
                  T

                  • 6. Re: Nukes Timecard Modue
                    Viet Master

                    I don't know jboss IDE at all. If you have questions for it, there is a dedicated forum :

                    http://www.jboss.org/forum.jsp?forum=162

                    I can help you only for Nukes.

                    julien

                    • 7. Re: Nukes Timecard Modue
                      Steve Moyer Newbie

                      Here's an wonderful CRM/ERP/SCM package that already runs on a Jboss server. If you want to cut some development time, maybe all you need is the Nukes front end to the existing time accounting module. Here's the link:

                      http://www.compiere.org/

                      They are also accepting donations to make the system database independent (MySQL and PostgreSQL). Another worthy cause.