5 Replies Latest reply on Mar 4, 2004 1:09 PM by Dennis Przybyla

    Module started but not in Main Menu

    Dennis Przybyla Novice

      My module does not get any errors when I deploy it and it seems to say it was started; however, It is not appearing in the Main Menu and the blocks that call functions in it when clicked on a message tells me that the module is not started.

      Any ideas?

      Thanks,
      Dennis Przybyla
      Software Engineer II
      SNC

        • 1. Re: Module started but not in Main Menu
          jae Master

          those modules have been externalized from the main "jboss-service.xml" file in the nukes.sar

          execute the following ant target from the "nukes" (core) directory:

          deploy-components

          • 2. Re: Module started but not in Main Menu
            Dennis Przybyla Novice

            It is not a core module it is a developed module. I did notice the problem you mentioned above last night and found this solution in a post last night.

            This started to happen when I added blocks to the module. The blocks seem to work but the module does not show up in the Main Menu which I have deployed using the steps you mentioned.

            Thanks,

            • 3. Re: Module started but not in Main Menu
              Dennis Przybyla Novice

              I have found an error in the log I missed it before. Here it is:

              10:23:57,468 ERROR [URLDeploymentScanner] MBeanException: Exception in MBean ope
              ration 'checkIncompleteDeployments()'
              Cause: Incomplete Deployment listing:
              Packages waiting for a deployer:

              Incompletely deployed packages:

              MBeans waiting for classes:

              MBeans waiting for other MBeans:
              [ObjectName: nukes.modules:name=kingpin
              state: CONFIGURED
              I Depend On: nukes.modules:name=core
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Feedback
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Subscription
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/LovValues
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/DataLog
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/DataType
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Datum
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Elnot
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/ElnotLog
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/EventLog
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/FtpPackage
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/KingpinExport
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/LineItem
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Mission
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Package
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/PackageLog
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Repot
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/ReportLog
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Requirement
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Signal
              jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Tape

              Depends On Me: ]
              10:23:57,659 INFO [URLDeploymentScanner] Started jboss.deployment:type=Deployme
              ntScanner,flavor=URL
              10:23:57,759 INFO [MainDeployer] Deployed package: file:/C:/Program Files/JBoss
              /jboss-3.2.3/server/default/conf/jboss-service.xml
              10:23:57,769 INFO [Server] JBoss (MX MicroKernel) [3.2.3 (build: CVSTag=JBoss_3
              _2_3 date=200311301445)] Started in 1m:27s:890ms

              Is this telling me it is waiting for itself to start?

              Thanks,

              • 4. Re: Module started but not in Main Menu
                Sherman Wood Apprentice


                Your module is waiting for the core nukes.ear/MBean to deploy. Did the nukes.ear deploy successfully?

                Where did you put the kingpin.ear? It should be in /default/nukes


                Sherman

                • 5. Re: Module started but not in Main Menu
                  Dennis Przybyla Novice

                  Well, I figured it out. But the error message was not very helpfull. It was a misspelled depend.

                   jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Repot
                  


                  should have been

                   jboss.j2ee:service=EJB,jndiName=nukes/kingpin/Report