2 Replies Latest reply on Sep 12, 2008 1:33 PM by Brian D

    rich:panel lost skin in a rich:tab

    osvaldo gomez Newbie

      Hi,

      I'm newer with richfaces and JSF, I'm puting a rich:panel in a rich:tab but it lost it skin and it look on a flat way. This is the code:

      <rich:tabPanel>
      <rich:tab label="formulario">
      <rich:panel style="width: 40%; align: center;">
      <h:panelGrid columns="3">
      <f:facet name="header"><h:outputText value="PRUEBA" id="titulo"/></f:facet>
      <h:outputText value="Codigo:"/><h:inputText value="#{requestPrueba.codigo}" id="username" ></h:inputText>

      <h:outputText value="Descripcion:"/><h:inputText value="#{requestPrueba.descripcion}" id="pass" ></h:inputText>

      <h:outputText value="Valor:"/><h:inputText value="#{requestPrueba.valor}"></h:inputText>
      <h:panelGroup />
      <h:commandButton action="volver" value="Cancelar"></h:commandButton>
      <h:commandButton action="#{requestPrueba.modifDatos}" value="Modificar" onclick="return validate();"></h:commandButton>
      <h:commandButton action="#{requestPrueba.grabarDatos}" value="Insertar" onclick="return validate();"></h:commandButton>

      </h:panelGrid>
      </rich:panel>
      </rich:tab>
      </rich:tabPanel>

      Somebody knows wath wrong? or why it not work ?

      Any help is welcome.

      many thanks

      regards.

        • 1. Re: rich:panel lost skin in a rich:tab
          Ilya Shaikovsky Master

          could you please share screenshot any where?

          • 2. Re: rich:panel lost skin in a rich:tab
            Brian D Newbie

            Bumping of a very old topic here, but I am experiencing the same issue as described above (You know what they say... better to resurface and old topic...).

            Bugs 3634 and 2316 both talk about this issue... but 3634 was marked as a dupe of 2316 and 2316 was resolved nofix as an issue with Seam, I guess. The problem is I'm not using Seam and I've got this issue.

            I've gotten this bug in both Richfaces 3.2.1 and 3.2.2.

            We're using tomcat with vanilla jsf plus richfaces and facelets.

            I've stripped down my test page a ton, and this is what I've got:

            <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
            
            <html xmlns="http://www.w3.org/1999/xhtml"
             xmlns:f="http://java.sun.com/jsf/core"
             xmlns:c="http://java.sun.com/jsp/jstl/core"
             xmlns:ui="http://java.sun.com/jsf/facelets"
             xmlns:h="http://java.sun.com/jsf/html"
             xmlns:a4j="http://richfaces.org/a4j"
             xmlns:rich="http://richfaces.org/rich">
             <head>
             <title>Common</title>
             </head>
             <body>
             <rich:panel>
             Panel Content
             </rich:panel>
             </body>
            </html


            The generated HTML looks like this:

            ...
            
            <div class="dr-pnl rich-panel " id="j_id2">
            <div class="dr-pnl-b rich-panel-body " id="j_id2_body">
            Panel Content
            </div>
            </div>
            
            ...


            The thing is there is no style information associated to either of those div tags (I checked with Firebug). So put simply, the rich:panel has no style information whatsoever. From time to time while tweaking, refreshing or cleaning the project I am rarely able to get the style information to show up... but that is a rare thing.

            Any help with this would be greatly appreciated...

            Thanks in advance.

            Referenced Bugs: