2 Replies Latest reply on Sep 30, 2005 7:53 AM by Andrew Oliver

    Requires JDK5/JBAS4.0.3

    Andrew Oliver Master

      M4-preX as of my lastest checkins now requires JDK5 and JBAS4.0.3. If you revert the minor descriptor/build changes I made (just as commentting out) then it will still work on JBAS4.02, for now. I expect this to change in the next few days and 4.0.3 will be a requirement at least for using JAASUserRepository with APOP and compilation.

      I realize the JDK5 change will be somewhat controversial no matter when we make it, but it is probably not feasible to put a high load mail server out using JDK1.4 anyhow due to the inferiority of its garbage collector.

      Over the past week or so my productivity has been down due to illness and travel but it should be back up shortly. I aim to be over my now second acquired illness of the week very quickly. Not that I'm sitting on my butt, but the keyboard won't stay still.


        • 1. Re: Requires JDK5/JBAS4.0.3
          Michael Barker Apprentice

          I am a little confused about the JBAS 4.0.3 requirement. Should we be using the latest from CVS? I am currently using a vanilla 4.0.3 RC2 which required me to uncomment the hibernate references from the build file.


          • 2. Re: Requires JDK5/JBAS4.0.3
            Andrew Oliver Master

            Yes the change of combining the HAR/SAR deployer is POST 4.0.3RC2. 4.0.3-final is imminent. They even have created the SP1 branch despite 4.0.3 not yet being released....how is that for confidence! The changes I made yesterday for APOP with JAAS require the latest from the Branch_4_0 and are not in the 4.0.3 branch (I/Scott also had to make changes to JBAS security to support it). It will WORK with the "old" JBoss but you won't be able to use APOP + JaasUserRepository.