5 Replies Latest reply on Jun 14, 2006 10:25 PM by Jay Glass

    Error building source

    Ron Jawanda Novice

      I asked this in another thread.
      I tried JBOSS_HOME=3.2.5 and now 4.0.4 versions
      Both failed near the middle with

      BUILD FAILED
      C:\jboss-mail\build.xml:212: C:\jbossas4\jboss-4.0.4.GA\server\default\deploy\ej
      b3.deployer not found.

      Any idea why?
      Thanks


        • 1. Re: Error building source
          Aron Sogor Newbie

          You need to install with 4.0.4 and the ejb deployer enabled.
          without that option the stock .zip will not work.

          • 2. Re: Error building source
            Ron Jawanda Novice

            Is that the ejb3 container? I downloaded that and read the instructions. They seem wrong. It says to place the jars in the all/lib and all deploy directory. Then I rerun the build and it is looking in the default deploy. I copied them all over to the default deploy and default/lib directory and it compiled with a LOT of errors. I guess I should put the errors here but I'm at work.
            I wish there was simple instructions on how to build. I've been working with Jboss for years and I'm struggling.
            ie: it says we haven't tested it yet with 4.0 version yet your telling me 4.0. It doesn't say anything about the deployer.

            If I ever figure it out maybe I can update the docs?

            • 3. Re: Error building source
              Aron Sogor Newbie

              I use 4.0.4 install.jar check the option for ejb3deployer.

              • 4. Re: Error building source
                Ron Jawanda Novice

                I finally got it built.

                Copy all these to the default/deploy or default/lib directory.
                Not the all/lib all/deploy
                Also the last client*.jar don't exist in the ejb3 download.

                also used 4.0.4 of jboss
                set jboss_home=C:\jbossas4\jboss-4.0.4.GA

                Also get jdk 5.0 build 7.

                All this seemed to work now.

                Ron


                # Copy ejb3.deployer from the lib/ directory of the distribution to jboss-4.0.x/server/all/deploy
                # Copy ejb3-clustered-sfsbcache-service.xml from the lib/ directory of the distribution to jboss-4.0.x/server/all/deploy
                # Copy ejb3-entity-cache-service.xml from the lib/ directory of the distribution to jboss-4.0.x/server/all/deploy
                # Copy ejb3-interceptors-aop.xml from the lib/ directory of the distribution to jboss-4.0.x/server/all/deploy
                # Copy jboss-aop-jdk50.deployer from the lib/ directory of the distribution to jboss-4.0.x/server/all/deploy
                # Copy quartz-ra.rar from the lib/ directory of the distribution to jboss-4.0.x/server/all/deploy
                # Copy jboss-remoting.jar from the lib/ directory of the distribution to jboss-4.0.x/server/all/lib
                # Copy hibernate-annotations.jar from the lib/ directory of the distribution to jboss-4.0.x/server/all/lib
                # Copy hibernate-entitymanager.jar from the lib/ directory of the distribution to jboss-4.0.x/server/all/lib
                # Copy ejb3-persistence.jar from the lib/ directory of the distribution to jboss-4.0.x/server/all/lib
                # Copy quartz-all-1.5.2.jar from the lib/ directory of the distribution to jboss-4.0.x/server/all/lib
                # Copy jboss-ejb3-client.jar from the lib/ directory of the distribution to jboss-4.0.x/client
                # Copy jboss-annotations-ejb3.jar from the lib/ directory of the distribution to jboss-4.0.x/client
                # Copy hibernate-client.jar from the lib/ directory of the distribution to jboss-4.0.x/client
                # Remove jboss-aop.deployer/ from jboss-4.0.x/server/all/deploy
                # Start jboss up with the all configuration run.sh -c all

                • 5. Re: Error building source
                  Jay Glass Novice

                  andrew, and I think the relese notes state, that the mail server has not been tested on 4.0, only like 3.5 something? maybe thats part of the issue, i also responded to your other thread in users forum