5 Replies Latest reply on Feb 26, 2004 9:43 AM by johnreynolds

    JBossJ2EE.pdf is aparently corrupted

    johnreynolds Newbie

      I attempted to download the getting started pdf, both from my home machine and from my work, and apparently the file is corrupted.

      I am using the link on the page: http://jboss.org/docs/index

        • 1. [ERROR] NAKACK.handleXmitReq()
          johnreynolds Newbie

          All JBoss versions prior to 3.2.4 may have clustering generate this kind of exception under load:

          2004-03-28 02:47:27,450 DEBUG [org.javagroups.DefaultPartition] [Sun Mar 28 02:47:27 EST 2004] [ERROR] NAKACK.handleXmitRe
          q(): (requester=choqtap4:32794 (additional data: 19 bytes)) message with seqno=0 not found in sent_msgs ! sent_msgs=18 17
          16 15 14 13 12 11 10 9 8 7 6 5


          This is due to an error in JGroup default protocol configuration. You can easily fix that by editing the file deploy/cluster-service.xml by reordering the UNICAST and pbcast.STABLE protocols. The ClusterPartition MBeans the becomes:

          <mbean code="org.jboss.ha.framework.server.ClusterPartition"
           name="jboss:service=DefaultPartition">
          
           <!-- Name of the partition being built -->
           <attribute name="PartitionName">DefaultPartition</attribute>
           <!-- Determine if deadlock detection is enabled -->
           <attribute name="DeadlockDetection">False</attribute>
           <!-- The JGroups protocol configuration -->
           <attribute name="PartitionConfig">
           <Config>
           <!-- UDP: if you have a multihomed machine,
           set the bind_addr attribute to the appropriate NIC IP address -->
           <!-- UDP: On Windows machines, because of the media sense feature
           being broken with multicast (even after disabling media sense)
           set the loopback attribute to true -->
           <UDP mcast_addr="228.1.2.3" mcast_port="45566"
           ip_ttl="32" ip_mcast="true"
           mcast_send_buf_size="800000" mcast_recv_buf_size="150000"
           ucast_send_buf_size="800000" ucast_recv_buf_size="150000"
           loopback="false" />
           <PING timeout="2000" num_initial_members="3"
           up_thread="true" down_thread="true" />
           <MERGE2 min_interval="10000" max_interval="20000" />
           <FD shun="true" up_thread="true" down_thread="true"
           timeout="2500" max_tries="5" />
           <VERIFY_SUSPECT timeout="3000" num_msgs="3"
           up_thread="true" down_thread="true" />
           <pbcast.NAKACK gc_lag="50" retransmit_timeout="300,600,1200,2400,4800"
           max_xmit_size="8192"
           up_thread="true" down_thread="true" />
           <UNICAST timeout="300,600,1200,2400,4800" window_size="100" min_threshold="10"
           down_thread="true" />
           <pbcast.STABLE desired_avg_gossip="20000"
           up_thread="true" down_thread="true" />
           <FRAG frag_size="8192"
           down_thread="true" up_thread="true" />
           <pbcast.GMS join_timeout="5000" join_retry_timeout="2000"
           shun="true" print_local_addr="true" />
           <pbcast.STATE_TRANSFER up_thread="true" down_thread="true" />
           </Config>
           </attribute>
          
           </mbean>



          Cheers,


          Sacha


          • 2. Re: JBossJ2EE.pdf is aparently corrupted
            Juha Lindfors Master

            It is not corrupted. What version of Acrobat Reader are you using?

            • 3. Re: JBossJ2EE.pdf is aparently corrupted
              santoshsahu Newbie

              I have downloaded the file jbossj2ee.pdf and tried to open it with AR 4.05 and get the following

              "There was an error in opening the document - The viewer cannot decrypt this document"

              • 4. Re: JBossJ2EE.pdf is aparently corrupted
                sys user Master

                Two things-
                1. Check while downloading if download is complete or not.
                2. I downloaded it today and it worked fine. I am using AR 5.

                Soum.

                • 5. Re: JBossJ2EE.pdf is aparently corrupted
                  Juha Lindfors Master

                   

                  "santoshsahu" wrote:
                  tried to open it with AR 4.05


                  You need to upgrade your reader,