2 Replies Latest reply on Mar 18, 2005 6:13 AM by Matt Gall

    Trouble deploying Duke

    Raymond Gardner Newbie

      I'm trying to learn JBoss by going through the 'Getting Started' guide. However, I'm only on Chapter 4 and I'm having some dificulty. Here is the latest problem:


      14:32:52,359 WARN [verifier] EJB spec violation:
      Bean : CustomerBean
      Section: 22.2
      Warning: The Bean Provider must specify the fully-qualified name of the Java class that implements the enterprise bean's business methods in the <ejb-class> element.
      Info : Class not found on 'com.sun.ebank.ejb.customer.CustomerBean': Unexpected error during load of: com.sun.ebank.ejb.customer.CustomerBean, msg=Illegal field name "has inconsistent hierarchy" in class com/sun/ebank/ejb/customer/CustomerBean


      Does anybody know why this will happen?

      I previously got an error in ejbql on t.timestamp >= ?1. I read a posting on this forum that ejbql does not support >=. The suggested solution was to seperate it into (t.timeStamp > ?1 or t.timeStamp = ?1). Which I did and it seemed to correct the ejbql issue but now I get the issue above.

        • 1. Re: Trouble deploying Duke
          Raymond Gardner Newbie

          Nevermind! I got this working today.

          I started with a fresh installation of JBoss 4.0.1.
          I used Sun's tutorial 1.4 Update 4.
          I overlaid the JBoss tutorial files.
          I then stepped through Chapter 4 build and deploy instructions and it worked today.

          I swear I did this yesterday and it did not work.
          Maybe I had something else misconfigured.

          • 2. Re: Trouble deploying Duke
            Matt Gall Newbie

            Hi,

            I got the same problem but a refresh installation didn't change anything.

            I carefully download sun (update 4) and jboss (release 3) tutorial versions and tried with jboss 4.0.1 and j2sdk1.4.2_07 (I previously tried with j2sdk 1.5).

            If anyone has a clue, it would be helpful.

            It seems many jboss newbies (like me) experience problem compiling or deploying Duke's Bank. As I read somewhere I would be great if jboss could provide its own version of the tutorial.

            Thanks

            Matt