1 Reply Latest reply on May 16, 2007 10:23 AM by Peter Johnson

    JBoss 4.0.5 and JDK5_06, JDK5_11 and JDK 6

    keruke Newbie

      Hi,

      When i have readed the documentation obout JBoss AS 4.0.5 GA, the requirements say:

      1. JDK 5 (v1.5.0_06 recommended)
      2. Ant (v1.6.5 recommended)
      3. JBoss Application Server v4.0.5GA [with ejb3]

      I must run the application server under JDK 5 v1.5.0_06, but can i develop my proyects in other version?, for example if my AS use JDK 5_06, can i develop my application under JDK 5_11 or JDK 6???

      Must i develop my application with the same version that my application server is running?

      Thanks

        • 1. Re: JBoss 4.0.5 and JDK5_06, JDK5_11 and JDK 6
          Peter Johnson Master

          First, you can run JBoss 4.0.5GA using JDK 1.5.0_11. And actually it is recommended since 1.5.0_11 has the latest fixes. (This is especially important if you are running on Vista.) The recommendation of 1.5.0_06 was the minimum patch level for 1.5.0 that is acceptable.

          Second, you can develop applications using JDK 1.5.0_11 and run them using JDK 1.5.0_06, because they are both 1.5.0. But you cannot develop applications using JDK 6 and run them with any 1.5.0, if you do you will get a class version number exception.

          For Ant, you can use whatever version you want to build your apps. If you build JBoss itself, it comes with its own version of Ant, so that should not be an issue.