3 Replies Latest reply on Feb 26, 2008 7:00 AM by crowse

    Restarting W2003->JBOSS service reboots the server

    crowse Newbie

      When I try to restart the Jboss service from controlPanel-> Services->Jboss the entire machine reboots.

      There is no apparent way to stop this process once started

      This can cause much customer dissatisfaction.
      ------------------------
      running service.bat restart results in JVM-BIND erors (Port already in use)

      ----------------------
      Is there a way round this - I want my web to redeploy after altering connectors and Aliases

      Perhaps I am doing something wrong?

        • 1. Re: Restarting W2003->JBOSS service reboots the server
          Peter Johnson Master

          I assume by your mention of service.bat that you areu sing JBoss native to run JBossAS as a service? (There are multiple ways of running JBOssAS as a service, with JBoss Native being just one of them.)

          Are you saying that when you run service.bat from a command prompt that you get the JVM-BIND error? If so, let's get this fixed first. Once that is fixed then the service should run properly again. Could you post the full stack trace for the error?

          Also, have you tried to first stop the service and then start it again? Perhaps JBossAS is taking too long to shut down. Try stopping hte service and then use Task Manager to ensure that the java.exe process has stopped completely.

          By the way, I have JBossAS running as a service on a Windows Server 2003 machine using JBoss Native, so I know that it works just fine.

          • 2. Re: Restarting W2003->JBOSS service reboots the server
            crowse Newbie

            Hi PeterJ,
            Thanks for the fast response, unfortunately I was unable to get to the machine till now.

            Yes, I am using JBoss native.
            I need to set up Internet (196.2.99.198) and Intranet (196.168.0.10) ports to the same service on 8180

            My mods to server.xml are

            
            <Connector port="8180" address="${jboss.bind.address}"
             maxThreads="250" maxHttpHeaderSize="8192"
             emptySessionPath="true" protocol="HTTP/1.1"
             enableLookups="false" redirectPort="8143" acceptCount="100"
             connectionTimeout="20000" disableUploadTimeout="true" />
            
            <Connector port="8180" address="196.2.99.198"
             maxThreads="250" maxHttpHeaderSize="8192"
             emptySessionPath="true" protocol="HTTP/1.1"
             enableLookups="false" redirectPort="8243" acceptCount="100"
             connectionTimeout="20000" disableUploadTimeout="true" />
            
            <Connector port="8180" address="192.168.0.10"
             maxThreads="250" maxHttpHeaderSize="8192"
             emptySessionPath="true" protocol="HTTP/1.1"
             enableLookups="false" redirectPort="8343" acceptCount="100"
             connectionTimeout="20000" disableUploadTimeout="true" />
            

            and
            <Host name="hsc-dc"
             autoDeploy="false" deployOnStartup="false" deployXML="false"
             configClass="org.jboss.web.tomcat.security.config.JBossContextConfig"
             >
             <Alias>hsc-dc.hsc.local</Alias>
             <Alias>hsc-dc.hsc</Alias>
             <Alias>196.2.99.198</Alias>
             <Alias>192.168.0.10</Alias>
             </Host>
            
            


            This configuration works on my Linux test environment wher I hae control of the DNS and firewall - other than JBoss doesnt seem to like going directly to an IP ... even if I put the Aliases in the default server. I have no or very little control over the production box.

            The problem on startup occurs on the second connector immediately after localhost is bound. And, indeed, after waiting for JBoss to start localhost:8180 works fine - you can see it being bound immediately before the stack trace (below).

            The web manager reports that JBoss ${jboss.bind.address} is bound to hsc-dc at 192.168.0.10, but I cant get to this service - even if I remove the second from server.xml

            Version
            Version: 4.2.1.GA (build: SVNTag=JBoss_4_2_1_GA date=200707131606)
            
            Version Name: Trinity
            
            Built on: July 13 2007
             Environment
            Start date: Tue Feb 26 09:45:34 GMT+02:00 2008
            
            Host: hsc-dc (192.168.0.10)
            
            Base Location: file:/C:/hscweb/jboss-4.2.1.GA/server/
            
            Base Location (local): C:\hscweb\jboss-4.2.1.GA\server
            
            Running config: 'default'
            
            
            
            
            JVM - Hardware
            Hardware
            #CPU: 2
            
            OS: Windows 2003 5.2 (x86)
             JVM Environment
            Free Memory: 90 MB
            
            Max Memory: 493 MB
            
            Total Memory: 163 MB
            
            #Threads: 47
            
            JVM Version: 10.0-b19 (Sun Microsystems Inc.)
            
            JVM Name: Java HotSpot(TM) Server VM
            
            
            


            09:45:39,860 INFO [TransactionManagerService] Starting recovery manager
            09:45:39,985 INFO [TransactionManagerService] Recovery manager started
            09:45:40,000 INFO [TransactionManagerService] Binding TransactionManager JNDI R
            eference
            09:45:44,610 INFO [EJB3Deployer] Starting java:comp multiplexer
            09:45:47,203 INFO [ServiceEndpointManager] jbossws-1.2.1.GA (build=200704151756
            )
            09:45:49,094 INFO [AprLifecycleListener] The Apache Tomcat Native library which
             allows optimal performance in production environments was not found on the java
            .library.path: C:\hscweb\jboss-4.2.1.GA\bin\native;C:\WINDOWS\system32;C:\WINDOW
            S;C:\WINDOWS\System32\Wbem;C:\Program Files\Microsoft Windows Small Business Ser
            ver\Networking\;C:\Program Files\Microsoft SQL Server\80\Tools\BINN;C:\hscweb\jd
            k1.6.0_04\bin;C:\hscweb\apache-maven-2.0.8\bin;C:\hscweb\jboss-4.2.1.GA\bin
            09:45:49,281 INFO [Http11Protocol] Initializing Coyote HTTP/1.1 on http-127.0.0
            .1-8180
            09:45:49,313 ERROR [Http11Protocol] Error initializing endpoint
            java.net.BindException: Cannot assign requested address: JVM_Bind:8180
             at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:501)
             at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:176)
            
             at org.apache.catalina.connector.Connector.initialize(Connector.java:105
            9)
             at org.apache.catalina.core.StandardService.initialize(StandardService.j
            ava:669)
             at org.apache.catalina.core.StandardServer.initialize(StandardServer.jav
            a:792)
             at org.apache.catalina.startup.Catalina.load(Catalina.java:518)
             at org.apache.catalina.startup.Catalina.start(Catalina.java:558)
             at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
             at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
            java:39)
             at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
            sorImpl.java:25)
             at java.lang.reflect.Method.invoke(Method.java:597)
             at org.apache.tomcat.util.modeler.BaseModelMBean.invoke(BaseModelMBean.j
            


            Restarting JBoss native from either the command line or start->admin->services forces a reboot with the following log entry (Event 1074)

            
            The process winlogon.exe has initiated the power off of computer HSC-DC on behalf of user HSC\Administrator for the following reason: No title for this reason could be found
             Reason Code: 0x840000ff
             Shutdown Type: power off
             Comment:
            
            For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
            


            I have tried manual stop - check task manager - start as suggested, with the box simply rebooting immediately. hence my dilemma

            I have in the interim removed JBoss native whilst I debug the command line version. I will also be trying glassfish since it seems to offer comfortable remote administration.

            I am glad to hear the JB is stable on win2K - I have no reason to suspect it isnt since I have been using JB and Tomcat on Linux for many years, and have seen that the paralell Windows version ahs been available for a ong time. I'm sure its something I've overlooked.

            Your help is much appreciated
            Chris

            • 3. Re: Restarting W2003->JBOSS service reboots the server
              crowse Newbie

              OK, so kick me (please)

              The net admin changed their router / firewall to NAT a few days ago, so the server now only has one IP - 192.168.0.10.

              As a result, the on non existant IPs were failing causing all subsequent in server.xml to be ignored.

              I'm running off the command line, and will leave JB in that state for a while - I dont want tio be responsible for any more server downtime just yet.

              Thanks PeterJ for informing me that the server (native) works OK - at least I was able to rule that out as a cause of the problem.

              Now to go to Zonedit and create a DNS fro the Internet IP and I'm away

              Many thanks PeterJ
              Chris