2 Replies Latest reply on Jan 23, 2009 1:34 AM by Muhammad Kashif

    Jboss not accessible on remote server.

    Muhammad Kashif Newbie

      HI All,

      i am facing a problem with jboss while accessing it from remote machine. i hope some1 will b able to find its solution for me.

      i have installed lastes available jboss (jboss-5.0.0.GA) on a linux machine. now when i start jboss, it starts successfully on 8080 port on that machine as i can it in logs. but when i try to access it from my machine from browser using ip of that machine like (http://192.168.0.1:8080 where 192.168.0.1 is the ip of machine where jboss is installed). it shows me "page can not be displayed".

      Now when i check for firewall. there is no firewall configured. server is listening on 8080 port (telnet 192.168.0.1 8080) but page is not displaying.

      now when i stop jboss and start tomcat on same linux machine and same port then i am able to access page of tomcat using url (http://192.168.0.1:8080).

      now there is one more thing.

      when jboss is up and i use command lynx http://127.0.0.1:8080 on linux server then it shows me jboss page on that machine without graphics... means jboss is up and running for its local host... but not from oustside the machine...

      but i have not done anything particular with configuration of jboss...
      also i have tried to use different remote servers but no success. also i have tried it by changing my own machine that was used to access server but still same case...


      so...can anyone please tell me where am i doing wrong?

      Thanks in advance

      Kashif