1 Reply Latest reply on Jan 28, 2005 8:58 PM by Scott Stark

    NoSuchMethodError when using remoting.jar from HEAD in JBoss

    mazz Master

      I've worked around this problem up to now, but its time I figure out what's wrong :-)

      Before, I had to build from HEAD the jar jboss-common.jar and put that in my jboss-4.0/lib directory. If I don't do that, and I run my JBossAS where a JBoss/Remoting server is running, I get this NoSuchMethodError:

      Caused by: java.lang.NoSuchMethodError: org.jboss.util.propertyeditor.PropertyEditors.mapJavaBeanProperties(Ljava/lang/Object;Ljava/util/Properties;Z)V
       at org.jboss.remoting.transport.socket.SocketServerInvoker.setup(SocketServerInvoker.java:122)
       at org.jboss.remoting.transport.socket.SocketServerInvoker.<init>(SocketServerInvoker.java:99)
       ... 97 more
      
      


      This happens on both 4.0 and 4.0.1

      Any insights on how to fix this - that is, without requiring a new build of jboss-common? I tried putting jboss-common.jar in my sar's /lib directory, but I get the same exception (probably due to the UCL picking up the jar in JBOSS_HOME/lib??)

      the remoting jar I have is built out of HEAD (I couldn't use the alpha release - there was a bug that caused me to upgrade to HEAD).