As time goes by, I am finding the interface "Context" to be increasingly confusing of a name - especially since creating a "ContextContext" interface on the server side of a request channel. In the Remoting spirit, I think that "Client" would be a better name for this interface. Related interfaces would become "ClientContext", "ClientSource", "ClientIdentifier".
Sounds good? If there's no objections I'll make this change for the M2 release.
I can't agree more. Sounds good!