6 Replies Latest reply on May 26, 2004 12:10 PM by jae

    Issues with 5/25 snapshot

    Gary Cuozzo Newbie

      Just FYI, I'm testing nukes for a potential deployment and came across a few problems so far. Platform is linux, db is mysql.

      1. When running the installer, I had some problems (permissions) that required me to back up and recreate the tables. I told the installer to run the drop table scripts, but there appear to be 2 tables that don't get dropped and I got an error that they already existed.
      2. I just tried to create a quote and it supposedly worked according to the UI, but in the logs I see: 12:04:09,489 ERROR [quotes] Cannot retrieve quotes
      javax.ejb.FinderException: Find failed: java.sql.SQLException: Column not found, message from server: "Unknown column 't0_s.pn_id' in 'field list'"

      I'll report any other problems as I find them.

      Cheers.

        • 1. unable to compile latest cvs
          jae Master

          by following instructions reported here:

          http://www.jboss.org/developers/projects/nukes/build

          i got these errors when trying to build:

          F:\nukes\nukes>build
          Executing F:\nukes\nukes\..\tools\bin\ant.bat -logger org.apache.tools.ant.NoBa
          nnerLogger
          Buildfile: build.xml

          _buildmagic:init:
          Trying to override old definition of task property
          [echo] F:\nukes/build/etc/mysql.properties

          generate-classes:
          [ejbdoclet] (XDocletMain.start 47 ) Running

          [ejbdoclet] (XDocletMain.start 47 ) Running <localhomeinterfa
          ce/>
          [ejbdoclet] (XDocletMain.start 47 ) Running <deploymentdescri
          ptor/>
          [ejbdoclet] (XDocletMain.start 47 ) Running
          [ejbdoclet] INFO: Some classes refer to other classes that were not found amo
          ng the sources or on the classpath.
          [ejbdoclet] (Perhaps the referred class doesn't exist? Hasn't been gene
          rated yet?)
          [ejbdoclet] The referring classes do not import any fully qualified cla
          sses matching these classes.
          [ejbdoclet] However, since no packages are imported, xjavadoc has assum
          ed that the referred classes
          [ejbdoclet] belong to the same package as the referring class. The clas
          ses are:
          [ejbdoclet] F:\nukes\nukes\src\main\org\jboss\nukes\core\ejb\FileEJB.java --> Co
          mmand qualified to org.jboss.nukes.core.ejb.Command
          [ejbdoclet] F:\nukes\nukes\src\main\org\jboss\nukes\core\ejb\FileEJB.java --> Ac
          tion qualified to org.jboss.nukes.core.ejb.Action
          [ejbdoclet] F:\nukes\nukes\src\main\org\jboss\nukes\core\ejb\FileEJB.java --> Fi
          leCommand qualified to org.jboss.nukes.core.ejb.FileCommand

          _default:compile-classes:
          [depend] Deleted 0 out of date files in 0 seconds
          [javac] Compiling 211 source files to F:\nukes\nukes\output\classes
          [javac] F:\nukes\nukes\src\main\org\jboss\nukes\io\HeadWriter.java:12: packa
          ge org.jboss.nukes.common.io does not exist
          [javac] import org.jboss.nukes.common.io.ReusableCharArrayReader;
          [javac] ^
          [javac] F:\nukes\nukes\src\main\org\jboss\nukes\io\HeadWriter.java:13: packa
          ge org.jboss.nukes.common.html does not exist
          [javac] import org.jboss.nukes.common.html.HeadAnalyzer;
          [javac] ^
          [javac] F:\nukes\nukes\src\main\org\jboss\nukes\io\HeadWriter.java:14: packa
          ge org.jboss.nukes.common.html does not exist
          [javac] import org.jboss.nukes.common.html.Token;
          [javac] ^
          [javac] F:\nukes\nukes\src\main\org\jboss\nukes\io\HeadWriter.java:15: packa
          ge org.jboss.nukes.common.chars does not exist
          [javac] import org.jboss.nukes.common.chars.MutableChars;
          [javac] ^

          (and so on...)

          what's wrong?

          • 2. Re: Issues with 5/25 snapshot
            Gary Cuozzo Newbie

            I just created a poll and told it to be on the right side. It showed up on the left. When I tried to move it, I see:

            12:10:25,443 INFO [JDBCDeploymentScanner] Deployed nukes.blocks:name=poll,id=1
            12:10:52,004 ERROR [Page] Some error occured
            javax.management.InstanceNotFoundException: nukes.blocks:name=poll is not registered.

            • 3. Re: Issues with 5/25 snapshot
              jae Master

              the quotes module is not "officially" supported right now, but thx for reporting that bug. it will be re-released and cleaned up in a future version of nukes.

              the modules slated for the 1.1 release are:

              - core
              - forums (bb)
              - news
              - downloads

              feel free to take these guys for a spin, but don't try to create the tables for the news or downloads module via the installer. both are "pure" cmp implementations and are setup to have jboss create the tables upon deployment (it's too much of a pita to maintain multiple ddls - all nukes modules will eventually move to this).

              also, there have been reports that the snapshots are not being built properly - ie: you may get "template not found errors" when trying to deploy the news module, but the templates really are there. i'd recommend just grabbing the code from cvs and working w/ that instead.

              • 4. Re: Issues with 5/25 snapshot
                Gary Cuozzo Newbie

                Very well. I'll try and beat on the supported modules and report any issues that I find. Do you care to hear about other problems right now? Or would you rather just focus on the supported modules?

                I think the pure CMP implementation will be nice. PostgreSQL is my preferred DB, but I've had lots of problems in the past with the DDL being broken.

                I'll try CVS again too. Yesterday, I was unable to attache to sourceforge CVS server (timeouts all day long), which is why I gave the snapshot a try.

                Thanks and good work!

                • 5. Re: Issues with 5/25 snapshot
                  jae Master

                  it'd be great if you could report other issues, but for now i'd just focus on what's going to be released.

                  i had to put in a "hack" to get postgres working w/ the pure cmp solution, and i just read another post that should allow me to remove that hack. if it works, it will affect the way data in the db is persisted, so don't get to attached to any of it until the official release (right now 0's are used instead of null values b/c of the way the tables are being created.

                  you can read about the postgres topic here: http://www.jboss.org/index.html?module=bb&op=viewtopic&p=3836283

                  • 6. Re: Issues with 5/25 snapshot
                    slewsys Newbie

                    This may be off base and perhaps even wrong, but here is how I got
                    PostgreSQL working: change all declarations of `SERIAL PRIMARY KEY NOT NULL' to just `SERIAL PRIMARY KEY'. As per the PostgreSQL documentation, both `SERIAL' and `PRIMARY KEY' imply `NOT NULL'
                    (see
                    <http://www.postgresql.org/docs/7.4/interactive/ddl-constraints.html#AEN1972> and < http://www.postgresql.org/docs/7.4/interactive/datatype.html#DATATYPE-SERIAL>).

                    For whatever reason, after doing this, I am able to insert without error.
                    Here is the list of changed files:

                    M adminmessages/src/resources/postgresql/setup.xml
                    M bb/src/resources/postgresql/setup.xml
                    M faq/src/resources/postgresql/setup.xml
                    M journal/src/resources/postgresql/setup.xml
                    M list/src/resources/postgresql/setup.xml
                    M news/src/resources/postgresql/setup.xml
                    M nukes/src/resources/postgresql/setup.xml
                    M polls/src/resources/postgresql/setup.xml
                    M quotes/src/resources/postgresql/setup.xml
                    M sections/src/resources/postgresql/setup.xml