Can we stop worrying about what things are called.
Read Humpty Dumpty by Lewis Carol.
If you don't like it feel free to change it, I don't care.
registerEntry() is to be consistent with unregisterEntry(Object)
If it were unregister(Object), it might not play well with other interfaces
with the same method name but different semantics.
Since this is intended to wrap/mixin with other "registry" implementations
this is likely.