I have a thing with names, so :)
1) KernelFactory initializes a Kernel, so it could be "KernelInitializer"
2) KernelConfig can be confused with KernelConfigurator. KernelConfig instantiates the Kernel "components" or "services" so maybe a better name is KernelServiceFactory or KernelComponentFactory or even KernelBoot. It could also move from spi.config to spi.bootstrap
I think it helps to have as much self-describing names as possible. I could apply those, if they are ok.
This forum was put into the archive on the 9th September 2004, you will get more help in the beginners corner forum.