1 Reply Latest reply on Jul 16, 2007 10:06 AM by Adrian Brock

    Missing artifact breaking build

    Ales Justin Master

      Is this intentional?
      Not yet commiting all the stuff - being forced by Sacha. :-)

      [WARNING] Unable to get resource 'jboss:jboss-classloading-spi:jar:5.0.0-SNAPSHOT' from repository jboss-snapshots (http://snapshots.jboss.org/maven2)
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Failed to resolve artifact.
      
      Missing:
      ----------
      1) jboss:jboss-classloading-spi:jar:5.0.0-SNAPSHOT
      
       Try downloading the file manually from the project website.
      
       Then, install it using the command:
       mvn install:install-file -DgroupId=jboss -DartifactId=jboss-classloading-spi \
       -Dversion=5.0.0-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
      
       Path to dependency:
       1) org.jboss.microcontainer:jboss-classloader:jar:2.0.0-SNAPSHOT
       2) jboss:jboss-classloading-spi:jar:5.0.0-SNAPSHOT
      
      ----------
      1 required artifact is missing.
      
      for artifact:
       org.jboss.microcontainer:jboss-classloader:jar:2.0.0-SNAPSHOT
      
      from the specified remote repositories:
       central (http://repo1.maven.org/maven2),
       jboss-snapshots (http://snapshots.jboss.org/maven2),
       repository.jboss.org (http://repository.jboss.org/maven2/),
       snapshots.jboss.org (http://snapshots.jboss.org/maven2/),
       jboss (http://repository.jboss.org/maven2)