0 Replies Latest reply on Jul 21, 2005 3:48 PM by fabio quimbay

    I cannot load tags of myfaces 1.0.9 (20050711) in Eclipse 3.

    fabio quimbay Newbie

      I try to refer me to the tags of myfaces on a JSP page from Eclipse 3.1 final, but I can't. The lines that I include in "index.jsp" are:

       <%@ taglib uri="http://java.sun.com/jsf/html"; prefix="h"%>
       <%@ taglib uri="http://java.sun.com/jsf/core"; prefix="f"%>
       <%@ taglib uri="http://myfaces.apache.org/extensions"; prefix="x"%>
      

      Ctrl + [SPACE] but it does not show any tag to me of <h:..>, <f:..> or <x:..>. This is the etructure of archives that I am handling:
       src/
       |_ WEB-INF/
       |_ lib/
       |_ jstl.jar
       |_ myfaces-api.jar
       |_ myfaces-impl.jar
       |_ standard.jar
       |_ tomahawk.jar
       |_ tlds/
       |_ myfaces_core.tld
       |_ myfaces_ext.tld
       |_ myfaces_html.tld
       |_ taglib.tld
       |_ web.xml
       |_ index.jsp
      

      In the file "web.xml" or "taglibs.xml"I have put the lines (but doesn't work):
       ...
       <taglib>
       <taglib-uri>http://java.sun.com/jsf/html</taglib-uri>
       <taglib-location>/WEB-INF/tlds/myfaces_html.tld</taglib-location>
       </taglib>
       <taglib>
       <taglib-uri>http://java.sun.com/jsf/core</taglib-uri>
       <taglib-location>/WEB-INF/tlds/myfaces_core.tld</taglib-location>
       </taglib>
       <taglib>
       <taglib-uri>http://myfaces.apache.org/extensions</taglib-uri>
       <taglib-location>/WEB-INF/tlds/myfaces_ext.tld</taglib-location>
       </taglib>
       ...
      

      Also, I I have put this lines in "XDoclet Configurations/Web/":
       webdoclet
       destDir = src/WEB-INF
       deploymentdescriptor
       mergeDir = src/WEB-INF
       jsptaglib
       mergeDir = src/WEB-INF
      

      In log of eclipse I don't see any warning or error. But it doesn't work either. It wanted to comment that I don't have any problem deploying or using the application, single desire to know as I can load tags of myfaces from eclipse in a JSP page. At the moment, I work with Eclipse 3,1 end, JBossIDE-1.5M2-ALL, JDK-1_5_0_04 and myfaces 1.0.9 (20050711). Thanks, for your help.