1 Reply Latest reply on Aug 10, 2005 10:26 AM by Mihai Postelnicu

    jboss-ide cannot configure server navigator

    Edwin Litterst Newbie

      Hi,

      I installed eclipse 3.1 and jboss-ide (JBossIDE-1.4.1-jre1.5-e31.zip) as plugin, I am using java1.5.
      When I am trying to configure a new server for the server navigator I get "An error has occurred..." when I am clicking "new" for any jboss server version.
      The log file contains:
      -----
      !ENTRY org.eclipse.jface 4 2 2005-08-10 11:03:58.93
      !MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
      !STACK 0
      java.lang.NoSuchMethodError: org.eclipse.jdt.internal.debug.ui.launcher.LauncherMessages.getString(Ljava/lang/String;)Ljava/lang/String;
      at org.jboss.ide.eclipse.launcher.ui.configuration.ServerLaunchArgumentsTab.createControl(ServerLaunchArgumentsTab.java:86)
      ...
      -----

      I read in other (older) postings that 1.4.1 is not runinng with eclipse 3.1 but from the name of my zip file to install I guess that it's exactly for this combination.
      Am I doing wrong something (I extracted the package to my eclipse directory so that everything went into features and plugin) or should this combination still not used?

      TIA,
      Eddie