5 Replies Latest reply on Sep 6, 2005 8:16 AM by Johannes Smutny

    Eclipse 3.1 + JBossIDE M2 Update + TrailBlazer

    Bob Johnson Newbie

      Is there anyone who succeeded in following the JBossIDE TrailBlazer with Eclipse 3.1 after copying files from the zip package to update JBossIDE to 1.5 M2 version?

      Problems come in particular in code completion after the "@". It doesn't show me the TAGS to generate code for the first Entity!

      I'm on Linux Suse 6.2 and using a JBoss 4.0.3 RC1 release.

      Thanks.

        • 1. Re: Eclipse 3.1 + JBossIDE M2 Update + TrailBlazer
          Bob Johnson Newbie

          Ooops. Found the right message on this forum for the same problem...

          Sorry! ;-)

          • 2. Re: Eclipse 3.1 + JBossIDE M2 Update + TrailBlazer
            Shai Bentin Newbie

            I have the same problem. Could not find the post you were referring to. Please direct me to the solution you found.

            Thanks

            • 3. Re: Eclipse 3.1 + JBossIDE M2 Update + TrailBlazer
              magic aldo Newbie

              It's because a lib isn't included in the Eclipse "Java Build Path" of the project (I test with Eclipse WTP 0.7 + JBoss 4.0.3RC2 + M2 plugin) : add ejb2-persistance.jar from server/default/deploy/ejb3.deployer to your build path.
              The other libs required are :
              - JBoss EJB3 Libraries
              - J2EE 1.4 Libraries (JBoss-IDE)

              That will maje Eclipse recognize @Entity and the like annonations with auto-completion.

              Another trick I add to do is specify explicitely in the build path the libs from MyFace.org and from Jakarta TagLibs 1.1
              I hope this will help you

              • 4. Re: Eclipse 3.1 + JBossIDE M2 Update + TrailBlazer
                Johannes Smutny Newbie

                I had the same problem with auto completion of ejb3 spec. I followed all the instruction of the trailblazer. No completion happened. Then I saw this and followed and code completion happened:

                Eclipse 3.x

                1. Right click on the top toolbar.
                2. Select Customize Perspective.
                3. Select Commands.
                4. Check Default Server in the Available Command Groups pane.
                5. Click OK.


                Addtitionally while installing the jboss server before, I named the configuration "all2 and not defualt as suggested. With that I realized that no libs were missing anymore in eclipse when setting up a new ejb3 project. No red cross displayed at the project folder. Hope this helps



                "magic34" wrote:
                It's because a lib isn't included in the Eclipse "Java Build Path" of the project (I test with Eclipse WTP 0.7 + JBoss 4.0.3RC2 + M2 plugin) : add ejb2-persistance.jar from server/default/deploy/ejb3.deployer to your build path.
                The other libs required are :
                - JBoss EJB3 Libraries
                - J2EE 1.4 Libraries (JBoss-IDE)

                That will maje Eclipse recognize @Entity and the like annonations with auto-completion.

                Another trick I add to do is specify explicitely in the build path the libs from MyFace.org and from Jakarta TagLibs 1.1
                I hope this will help you



                • 5. Re: Eclipse 3.1 + JBossIDE M2 Update + TrailBlazer
                  Johannes Smutny Newbie

                  import the following jars to the building path of an ejb3 project, in order to be able
                  to construct session and messagge beans with code completion:

                  add external archives:
                  located in:
                  \server\all\deploy\ejb3.deployer:
                  named:
                  ejb3-persistance.jar
                  jboss-ejbr.jar
                  jboss-ejb3x.jar

                  add libraries:
                  J2EE 1.4 Libraries (JBOSS-IDE)


                  OS: XP prof.
                  Eclipse 3.1

                  jboss ide v.1.5 M2

                  hope this helps