2 Replies Latest reply on Feb 20, 2006 6:11 AM by Vincent FUCHS

    launching is stopped, like in debug mode

    Vincent FUCHS Newbie

      Hi,

      I've been trying to launch JBoss from Eclipse for hours now, and I've found why it doesn't work, but I still don't know how to solve the problem.
      I'm using Eclipse 3.1.0, JBossIDE 1.5 and JBoss 4.0.4 .
      I did as said in various tutorials, and Jboss seems to be launched (in server navigator, it says "running"). But in fact it's not. I've set to "none" the perpective to be opened when I launch the server. Some stuff is written in the console :

      15:44:45,872 INFO [Server] Starting JBoss (MX MicroKernel)...
      15:44:45,903 INFO [Server] Release ID: JBoss [Zion] 4.0.4RC1 (build: CVSTag=JBoss_4_0_4_RC1 date=200602071519)
      15:44:45,997 INFO [Server] Home Dir: C:\jboss-4.0.4RC1
      15:44:45,997 INFO [Server] Home URL: file:/C:/jboss-4.0.4RC1/
      15:44:45,997 INFO [Server] Patch URL: null
      15:44:45,997 INFO [Server] Server Name: default
      15:44:45,997 INFO [Server] Server Home Dir: C:\jboss-4.0.4RC1\server\default
      15:44:45,997 INFO [Server] Server Home URL: file:/C:/jboss-4.0.4RC1/server/default/
      15:44:45,997 INFO [Server] Server Temp Dir: C:\jboss-4.0.4RC1\server\default\tmp
      15:44:45,997 INFO [Server] Root Deployment Filename: jboss-service.xml
      15:44:48,340 INFO [ServerInfo] Java version: 1.5.0_03,Sun Microsystems Inc.
      15:44:48,340 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.5.0_03-b07,Sun Microsystems Inc.
      15:44:48,340 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
      15:44:50,700 INFO [Server] Core system initialized
      15:44:54,684 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.xml
      15:45:04,528 INFO [SocketServerInvoker] Invoker started for locator: InvokerLocator [socket://10.251.100.193:3873/]
      15:45:09,278 INFO [AspectDeployer] Deployed AOP: file:/C:/jboss-4.0.4RC1/server/default/deploy/ejb3-interceptors-aop.xml
      15:45:22,449 INFO [WebService] Using RMI server codebase: http://PARW00047747:8083/
      15:45:23,027 WARN [EJBTimerServiceImpl] Cannot obtain TransactionManager from JNDI, using TxManager.getInstance(): javax.naming.NameNotFoundException: TransactionManager not bound
      15:45:24,387 INFO [TreeCache] setting cluster properties from xml to: UDP(ip_mcast=true;ip_ttl=64;loopback=false;mcast_addr=228.1.2.3;mcast_port=45551;mcast_recv_buf_size=80000;mcast_send_buf_size=150000;ucast_recv_buf_size=80000;ucast_send_buf_size=150000):PING(down_thread=false;num_initial_members=3;timeout=2000;up_thread=false):MERGE2(max_interval=20000;min_interval=10000):FD(down_thread=true;shun=true;up_thread=true):VERIFY_SUSPECT(down_thread=false;timeout=1500;up_thread=false):pbcast.NAKACK(down_thread=false;gc_lag=50;max_xmit_size=8192;retransmit_timeout=600,1200,2400,4800;up_thread=false):UNICAST(down_thread=false;min_threshold=10;timeout=600,1200,2400;window_size=100):pbcast.STABLE(desired_avg_gossip=20000;down_thread=false;up_thread=false):FRAG(down_thread=false;frag_size=8192;up_thread=false):pbcast.GMS(join_retry_timeout=2000;join_timeout=5000;print_local_addr=true;shun=true):pbcast.STATE_TRANSFER(down_thread=false;up_thread=false)
      15:45:24,543 INFO [TreeCache] setEvictionPolicyConfig(): [config: null]
      15:45:24,621 WARN [TreeCache] No transaction manager lookup class has been defined. Transactions cannot be used
      15:45:24,730 INFO [TreeCache] interceptor chain is:
      class org.jboss.cache.interceptors.CallInterceptor
      class org.jboss.cache.interceptors.LockInterceptor
      class org.jboss.cache.interceptors.CacheLoaderInterceptor
      class org.jboss.cache.interceptors.UnlockInterceptor
      class org.jboss.cache.interceptors.ReplicationInterceptor
      class org.jboss.cache.interceptors.CacheStoreInterceptor
      15:45:24,809 INFO [TreeCache] cache mode is REPL_SYNC
      15:45:25,887 INFO [STDOUT]
      -------------------------------------------------------
      GMS: address is PARW00047747:1791
      -------------------------------------------------------
      15:45:28,137 INFO [TreeCache] state could not be retrieved (must be first member in group)
      15:45:28,137 INFO [LRUPolicy] Starting eviction policy using the provider: org.jboss.ejb3.cache.tree.StatefulEvictionPolicy
      15:45:28,152 INFO [LRUPolicy] Starting a eviction timer with wake up interval of (secs) 1
      15:45:28,152 INFO [TreeCache] new cache is null (maybe first member in cluster)
      15:45:28,184 INFO [TreeCache] viewAccepted(): new members: [PARW00047747:1791]
      15:45:28,684 INFO [TreeCache] setting cluster properties from xml to: UDP(ip_mcast=true;ip_ttl=2;loopback=false;mcast_addr=228.1.2.3;mcast_port=43333;mcast_recv_buf_size=80000;mcast_send_buf_size=150000;ucast_recv_buf_size=80000;ucast_send_buf_size=150000):PING(down_thread=false;num_initial_members=3;timeout=2000;up_thread=false):MERGE2(max_interval=20000;min_interval=10000):FD(down_thread=true;shun=true;up_thread=true):VERIFY_SUSPECT(down_thread=false;timeout=1500;up_thread=false):pbcast.NAKACK(down_thread=false;gc_lag=50;max_xmit_size=8192;retransmit_timeout=600,1200,2400,4800;up_thread=false):UNICAST(down_thread=false;min_threshold=10;timeout=600,1200,2400;window_size=100):pbcast.STABLE(desired_avg_gossip=20000;down_thread=false;up_thread=false):FRAG(down_thread=false;frag_size=8192;up_thread=false):pbcast.GMS(join_retry_timeout=2000;join_timeout=5000;print_local_addr=true;shun=true):pbcast.STATE_TRANSFER(down_thread=false;up_thread=false)
      15:45:28,730 INFO [TreeCache] setEvictionPolicyConfig(): [config: null]
      15:45:44,683 INFO [MailService] Mail Service bound to java:/Mail


      and that's all. To make sure of it, I've switched to "debug" the perpective to be opened when launched, and I realized that the debugger stops on something in "properties.class", line 365,
      while (true) {
       if (inOff >= inLimit) {
       inLimit = inStream.read(inBuf);
       inOff = 0;
       if (inLimit <= 0) {
       if (len == 0 || isCommentLine) {
       return -1;
       }
       return len;
       }
      


      And when I click on "next" (actually several times, because it stops a few times again), the lauching keeps running and in the end it works fine.

      How does it come the debugger stops when there is no breakpoint ? is it because of the warning that appears in the log ([EJBTimerServiceImpl] Cannot obtain TransactionManager from JNDI, using TxManager.getInstance(): javax.naming.NameNotFoundException: TransactionManager not bound ) ? Can I force Eclipse to ignore that and continue the launching anyway ?

      Thanks in advance

      --
      Vince