5 Replies Latest reply on Aug 21, 2006 12:13 PM by Johans Marvin Taboada Villca

    jboss  by debug not avaliable

    andre yang Newbie

      i downloaded the eclipse jboss ide and clicked on the debug button, instead of 4 avalianble jboss modus(jboss 3.x server, jboss 4.x server) is only jboss AOP avaliable, what i did wrong?
      Andre

        • 1. Re: jboss  by debug not avaliable
          Rob Stryker Master

          You did nothing wrong. The new way to start or stop servers is in the JBoss Servers View.

          • 2. Re: jboss  by debug not avaliable
            Max Rydahl Andersen Master

            ...any reason why we don't support start/stop via a launchconfiguration ?

            just curious ;)

            • 3. Re: jboss  by debug not avaliable
              Rob Stryker Master

              Because I was told to situate myself solidly within the webtools framework and use the Server APIs... ... ... I'm adding what I can where I can to make it as painless for the user as possible.

              There will be a workbench icon + pulldown for those who dont want the servers view opened cluttering their workspace.

              • 4. Re: jboss  by debug not avaliable
                Max Rydahl Andersen Master

                ...and my point is that you don't have to do another icon+pulldown menu since you could just expose them as launchconfigurations (just a thought).

                anyhow all this is less relevant than provide easy migration from the old to the new ways.

                • 5. Re: jboss  by debug not avaliable [another error Pop Up?]
                  Johans Marvin Taboada Villca Newbie

                  Hi, first thing thanks for JBossIDE.
                  I used JBossIDE 1.5, and 1.6 with no problems, and as you may suppose, I have problems with JBossIDE-2.0.0.Alpha1a.
                  Eclipse pops up another error dialog (not the '50s Timeout '), it Says 'Server JBOSS 4.0 failed to start', seems pretty much like the 50s timeout (pops up almost the same time).
                  I checked the log and nothing of help:
                  !ENTRY org.eclipse.wst.server.core 4 0 2006-08-21 10:32:10.062
                  !MESSAGE Server JBOSS 4.0 failed to start.
                  While I was setting the server in the 'JBoss Server View' a error Pop Up, in the log:

                  !ENTRY org.eclipse.jface 4 2 2006-08-21 11:32:06.328
                  !MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
                  !STACK 0
                  org.eclipse.jface.util.Assert$AssertionFailedException: null argument;
                  at org.eclipse.jface.util.Assert.isNotNull(Assert.java:150)
                  ...
                  at org.jboss.ide.eclipse.as.ui.views.JBossServerView$2.selectionChanged(JBossServerView.java:183)
                  ...
                  at org.eclipse.core.launcher.Main.main(Main.java:952)

                  I can send the whole stack trace if needed.

                  This is my dist:
                  - wtp-sdk-M-1.5.1-200608110237.zip
                  Which ask for the next deps
                  - eclipse-sourceBuild-srcIncluded-M20060802-0800.zip
                  - emf-sdo-runtime-M200608030000.zip
                  - xsd-runtime-M200608030000.zip
                  - JEM-SDK-1.2.zip
                  - GEF-SDK-3.2.zip

                  Almost forgot, I used the following dist of JBoss-IDE (not the bundle):
                  - JBossIDE-2.0.0.Alpha1a-ALL.zip [Jul 17, 2006 08:48]

                  I switched to this dist because of the '50s timeout', willing to use the new JBossAs Adapter (to reduce my deplyment cycle, Hot code replacement).
                  Now I can select 'Time out: Unlimited', I configure the server (jboss-4.0.4.GA-src dist) from the Windows->Preferences->Server... Even I start the server from the new 'JBoss Server View'
                  ¿Any help, please?, maybe I built upon the wrong dist.
                  I'm going to try the [JBossIDE-2.0.0.Alpha1a-Bundle-win32.zip][Jul 17, 2006 10:03]
                  And next [JBossIDE-200608191448-integration-ALL.zip][Aug 20, 2006 12:15] ¿is my current dist able to support it?
                  Thanks, (¿is OK to post this here?)