1 Reply Latest reply on Aug 24, 2006 3:26 PM by Rob Stryker

    JBoss 4.0 Server can't be deleted

    Newbie

      I can't pinpoint the root cause, but at some point the 4.0 server instance I added was corrupted (I could open the "Overview" page, but I couldn't edit the runtime information in the general section nor did anything happen when I clicked "Open launch configuration").

      I tried deleting the server, but after I restarted Eclipse the instance came back in the Servers view. I tried it again: deleted the server, restarted Eclipse, it came back in the Servers view.

      I then deleted the server instance from the view, shut down Eclipse, deleted the Servers directory from my workspace, restarted Eclipse, but the instance was still in the Servers view. This time, when I opened it, the font color for the value in the "Configuration path" under General was of course red (because I deleted that directory).

      The AS 4.0 instance on the disk that it references is still alive, well, and kicking. So what's going on inside Eclipse? And how can I reliably delete the server?