4 Replies Latest reply on Sep 26, 2006 2:05 AM by Ole Matzura

    Cannot add J2EE Server

    Chuck Harris Newbie

      I am trying to add a jboss instance under Debug/J2EE Server but get an error when adding a new one. I am running eclipse 3.1.2 and jboss ide 1.6.0GA, workshop for struts 3.1.0. I am tring to generate a web service and then test it but without the server , that fails.

      The log :


      !ENTRY org.eclipse.jface 4 2 2006-09-21 06:41:36.299
      !MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.jface".
      !STACK 0
      java.lang.IllegalArgumentException: Argument cannot be null
      at org.eclipse.swt.SWT.error(SWT.java:2926)
      at org.eclipse.swt.SWT.error(SWT.java:2865)
      at org.eclipse.swt.SWT.error(SWT.java:2836)
      at org.eclipse.swt.widgets.Widget.error(Widget.java:395)
      at org.eclipse.swt.widgets.TableItem.setText(TableItem.java:1034)
      at com.bea.wstudio.debugger.WebAppServerLaunchConfigurationTab.setProjectCombo(Unknown Source)
      at com.bea.wstudio.debugger.WebAppServerLaunchConfigurationTab.handleServerSelection(Unknown Source)
      at com.bea.wstudio.debugger.WebAppServerLaunchConfigurationTab.setServerCombo(Unknown Source)
      at com.bea.wstudio.debugger.WebAppServerLaunchConfigurationTab.createControl(Unknown Source)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.showTabsFor(LaunchConfigurationTabGroupViewer.java:720)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.showInstanceTabsFor(LaunchConfigurationTabGroupViewer.java:639)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.displayInstanceTabs(LaunchConfigurationTabGroupViewer.java:519)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer$5.run(LaunchConfigurationTabGroupViewer.java:471)
      at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.inputChanged(LaunchConfigurationTabGroupViewer.java:488)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationTabGroupViewer.setInput(LaunchConfigurationTabGroupViewer.java:452)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationsDialog.handleLaunchConfigurationSelectionChanged(LaunchConfigurationsDialog.java:789)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationsDialog$3.selectionChanged(LaunchConfigurationsDialog.java:601)
      at org.eclipse.jface.viewers.StructuredViewer$3.run(StructuredViewer.java:763)
      at org.eclipse.core.internal.runtime.InternalPlatform.run(InternalPlatform.java:1044)
      at org.eclipse.core.runtime.Platform.run(Platform.java:783)
      at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:44)
      at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:148)
      at org.eclipse.jface.viewers.StructuredViewer.firePostSelectionChanged(StructuredViewer.java:761)
      at org.eclipse.jface.viewers.StructuredViewer.setSelection(StructuredViewer.java:1453)
      at org.eclipse.jface.viewers.Viewer.setSelection(Viewer.java:379)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationView.handleConfigurationRemoved(LaunchConfigurationView.java:359)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationView.launchConfigurationRemoved(LaunchConfigurationView.java:304)
      at org.eclipse.debug.internal.core.LaunchManager$ConfigurationNotifier.run(LaunchManager.java:1584)
      at org.eclipse.core.internal.runtime.InternalPlatform.run(InternalPlatform.java:1044)
      at org.eclipse.core.runtime.Platform.run(Platform.java:783)
      at org.eclipse.debug.internal.core.LaunchManager$ConfigurationNotifier.notify(LaunchManager.java:1605)
      at org.eclipse.debug.internal.core.LaunchManager.launchConfigurationDeleted(LaunchManager.java:787)
      at org.eclipse.debug.internal.core.LaunchConfiguration.delete(LaunchConfiguration.java:319)
      at org.eclipse.debug.internal.ui.launchConfigurations.DeleteLaunchConfigurationAction.performAction(DeleteLaunchConfigurationAction.java:65)
      at org.eclipse.debug.internal.ui.launchConfigurations.AbstractLaunchConfigurationAction$1.run(AbstractLaunchConfigurationAction.java:103)
      at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
      at org.eclipse.debug.internal.ui.launchConfigurations.AbstractLaunchConfigurationAction.run(AbstractLaunchConfigurationAction.java:106)
      at org.eclipse.ui.actions.BaseSelectionListenerAction.runWithEvent(BaseSelectionListenerAction.java:167)
      at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:538)
      at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:488)
      at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:400)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3125)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2758)
      at org.eclipse.jface.window.Window.runEventLoop(Window.java:809)
      at org.eclipse.jface.window.Window.open(Window.java:787)
      at org.eclipse.debug.internal.ui.launchConfigurations.LaunchConfigurationsDialog.open(LaunchConfigurationsDialog.java:439)
      at org.eclipse.debug.ui.DebugUITools$1.run(DebugUITools.java:356)
      at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
      at org.eclipse.debug.ui.DebugUITools.openLaunchConfigurationDialogOnGroup(DebugUITools.java:360)
      at org.eclipse.debug.ui.DebugUITools.openLaunchConfigurationDialogOnGroup(DebugUITools.java:302)
      at org.eclipse.debug.ui.actions.OpenLaunchDialogAction.run(OpenLaunchDialogAction.java:80)
      at org.eclipse.debug.ui.actions.OpenLaunchDialogAction.run(OpenLaunchDialogAction.java:99)
      at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:246)
      at org.eclipse.ui.internal.WWinPluginAction.runWithEvent(WWinPluginAction.java:223)
      at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:538)
      at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:488)
      at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:400)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3125)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2758)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1699)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:367)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:143)
      at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:103)
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
      at org.eclipse.core.launcher.Main.run(Main.java:973)
      at org.eclipse.core.launcher.Main.eclipse_main(Main.java:948)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at com.m7.installer.util.NitroxMain$1.run(NitroxMain.java:29)
      at java.awt.event.InvocationEvent.dispatch(Unknown Source)
      at java.awt.EventQueue.dispatchEvent(Unknown Source)
      at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
      at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
      at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
      at java.awt.EventDispatchThread.run(Unknown Source)

        • 1. Re: Cannot add J2EE Server
          Chuck Harris Newbie

          So i decided to start with a fresh eclipse and jboss ide. For the most part, generating a bottom up web service is working as expected. However, when i generate the web service and then test it, "-c default,all,minimal" is entered in the program arguments so the deployment fails:
          17:50:19,484 INFO [Server] Core system initialized
          Failed to boot JBoss:
          org.jboss.deployment.DeploymentException: url file:/C:/packages/jboss-4.0.1sp1/server/default,all,minimal/conf/jboss-service.xml could not be opened, does it exist?
          at org.jboss.deployment.DeploymentInfo.(DeploymentInfo.java:175)
          at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:737)

          I have changed it to "-c all" several times and it changes back whenever i start the server when generating a web service. I removed the "-c default,all,minimal" from eclipse\plugins\org.eclipse.jst.server.generic.serverdefinitions_1.0.0.v200603162041\servers\jboss323.serverdef and jboss.serverdef (using 4.01sp1) but it still changes it in the server config. Any idea how to get the -c all to stick.

          • 2. Re: Cannot add J2EE Server
            Rob Stryker Master

            You are creating a 'generic' jboss server, which is run by webtools and not JBoss IDE. JBoss IDE has their own server adapter and the forums have several times outlined how to create one.

            The webtools web-service support is also sketchy, and so JBoss IDE has people allocated to creating web service elements of our own. (I believe). I'm unsure of the status of that project.

            • 3. Re: Cannot add J2EE Server
              Chuck Harris Newbie

              Yes, I am creating a generic server. I didn't realize that it was outside the jboss ide. I can get around it by starting jboss prior to generating the web service. Thanks.

              • 4. Re: Cannot add J2EE Server
                Ole Matzura Novice

                Hi,

                Just to confirm your statement Rob, we are working on much improved webservice support for jbosside 2.0.0, the upcoming beta2 will have most features in place together with documentation and samples..

                regards!

                /Ole
                eviware.com