13 Replies Latest reply on Nov 7, 2006 12:37 PM by David Macklem

    JBoss Ide 2.0.0-Beta2 problem

    Giordano Vicoli Newbie

      Hello,

      I downloaded and installed the JBossIDE 2.0.0Beta2 bundle-win32. I tried starting a new EJB3.0 Project and the IDE asked me to create a new JBOSS Server configuration. In the last step of the wizard after I created the JBoss configuration the "Finish" button is disabled so I can't create a new project. Is a my problem or is a bug? I would like to underline that it is not the first time I use JBoss IDE and I know quite well this tool.

      Thanks and bye,
      Giordano

        • 1. Re: JBoss Ide 2.0.0-Beta2 problem
          Rob Stryker Master

          I just tried to replicate your issue and was unable to. Once you create a new server, simply selecting it should enable the finish button. Even if the server doesn't contain the ejb3 runtimes, the finish button will still be enabled (but it will then tell you it's not acceptable)

          • 2. Re: JBoss Ide 2.0.0-Beta2 problem
            Justin Xu Newbie

             

            "rob.stryker@jboss.com" wrote:
            I just tried to replicate your issue and was unable to. Once you create a new server, simply selecting it should enable the finish button. Even if the server doesn't contain the ejb3 runtimes, the finish button will still be enabled (but it will then tell you it's not acceptable)


            i have the same problem after using JBossIDE-2.0.0.Beta2, but using JBossIDE-2.0.0.Alapa1 is OK..

            SOS

            • 3. Re: JBoss Ide 2.0.0-Beta2 problem
              Matthew Sell Newbie

              Having the same problem with Beta 2 and JBoss 5 (built from source on September 6).

              When Beta 2 migrated my server configurations from IDE 1.5, and creating a new project, I select my JBoss configuration that was migrated from 1.5 and get the following error:

              "The selected configuration ("JBoss-5.0-Alpha") does not contain the expected EJB3 libraries. Please install JBoss with EJB3 enabled, or try another configuration."

              Attempting to "Create a JBoss Server" results in the same problem that "giordano" reported.

              I'll try a fresh build of JBoss 5 today, but failing that I'll just go back to using IDE 1.5 (which has been working fine for me).

              • 4. Re: JBoss Ide 2.0.0-Beta2 problem
                Rob Stryker Master

                 

                "msell" wrote:
                "The selected configuration ("JBoss-5.0-Alpha") does not contain the expected EJB3 libraries. Please install JBoss with EJB3 enabled, or try another configuration."


                This is intended. If your jboss installation does not contain the path server/jboss-ejb3.jar then it will not create an ejb3 project.

                "msell" wrote:
                Attempting to "Create a JBoss Server" results in the same problem that "giordano" reported.


                Once you create a new server, simply selecting any of the servers inside the dialog box should definitely enable the finish button, even if the finish doesn't work, the button itself *WILL* be enabled. You must SELECT the server from the list to enable the button though.

                So to recap, after creating a new server from the dialog, you must select it to enable the finish button. And if the server installation does not contain a server/jboss-ejb3.jar library file, you will not be able to make the EJB3 project and an error message will pop up AFTER pressing finish.

                If anyone's experiences contradict me, PLEASE write back with more information.

                • 5. Re: JBoss Ide 2.0.0-Beta2 problem
                  Matthew Sell Newbie

                  Not sure how things got straightened out, but somehow restarting Beta 2, and working through the steps again worked.

                  Everything appears to be working fine now - not quite sure why or how. I reproduced my steps from the first startup and the "finish" button was enabled this time.

                  Probably missed something the first time...

                  • 6. Re: JBoss Ide 2.0.0-Beta2 problem
                    Justin Xu Newbie

                     

                    "msell" wrote:
                    Not sure how things got straightened out, but somehow restarting Beta 2, and working through the steps again worked.

                    Everything appears to be working fine now - not quite sure why or how. I reproduced my steps from the first startup and the "finish" button was enabled this time.

                    Probably missed something the first time...



                    Now is working for u???
                    i try to create the new ejb3.0 project sometimes, the problem is the same..
                    my jboss as: jboss-4.0.4.GA\server\default\deploy\ejb3.deployer
                    and has the ejb3.0 jars. i believe my jboss server is Ok, before using JBOSS IDE Beta2.0, is running the EJB3.0 project.

                    • 7. Re: JBoss Ide 2.0.0-Beta2 problem
                      Joel Schuster Newbie

                      What is the difference b/t the server types JBoss and JBoss Inc?

                      I was getting the same problem with the Finish button not being available for a selected server instance installed as an EJB3 server installation.

                      This was when I set up my server installation as a JBoss v4.0 server type.

                      However, I was able to get my EJB3 project created if I used a JBoss Inc server type to define my server.

                      This also makes me wonder the difference b/t the JBoss Server View and Servers views.

                      Any enlightenment along these lines would be nice. Thanks.

                      • 8. Re: JBoss Ide 2.0.0-Beta2 problem
                        Max Rydahl Andersen Master

                        JBoss -> the Eclipse WTP provided JBoss adapter

                        JBoss Inc -> the (better) JBoss provided JBoss adapter for Eclipse WTP

                        • 9. Re: JBoss Ide 2.0.0-Beta2 problem
                          Justin Xu Newbie

                           

                          "guurk" wrote:
                          What is the difference b/t the server types JBoss and JBoss Inc?

                          I was getting the same problem with the Finish button not being available for a selected server instance installed as an EJB3 server installation.

                          This was when I set up my server installation as a JBoss v4.0 server type.

                          However, I was able to get my EJB3 project created if I used a JBoss Inc server type to define my server.

                          This also makes me wonder the difference b/t the JBoss Server View and Servers views.

                          Any enlightenment along these lines would be nice. Thanks.




                          i got the answer...Adding the JBoss Inc Server to the project can add the jars of jboss ejb3.0...

                          Create the JBoss Inc server is Ok....can finish...[/img]

                          • 10. Re: JBoss Ide 2.0.0-Beta2 problem
                            Giordano Vicoli Newbie

                            Yes,

                            I created a JBoss inc server and all is working.

                            many thanks and bye,

                            Giordano

                            • 11. Re: JBoss Ide 2.0.0-Beta2 problem
                              Justin Xu Newbie

                              hi, Giordano..

                              this my email: popgo.java@gmail.com;
                              can u leave your communication.

                              if u use the Google Talk, i can add you and talk with the ejb3 or java developing

                              Waiting!!

                              • 12. Re: JBoss Ide 2.0.0-Beta2 problem
                                Alexander Hachmann Newbie

                                Hello,
                                I am still having a strange Problem with this. I am using the full Beta2 Bundle for Windows.
                                When I want to create a JBoss Inc, i select the Server an press next to get to the Add Projects page. The heading will be changed to "Add and Remove Projects" but he window content stays the same.
                                And further more, the Finish button is never being enabled. Next and Back are activating and deaktivating, but the Finish Button definatley stays disabled :-/

                                Any suggestions?

                                Regards,
                                Alexander

                                • 13. Re: JBoss Ide 2.0.0-Beta2 problem
                                  David Macklem Newbie

                                  I'm having this same problem with "The selected configuration ("jBoss") does not contain the expected EJB3 libraries. Please install JBoss with EJB3 enabled, or try another configuration." but for a slightly different reason.

                                  I've found that if I install JBoss with a configuration name other than 'default' or 'all', I get this error message. The ejb3.deployer directory and jboss-ejb3.jars are in the server/xxx/deploy directory but it looks like the plug-in doesn't look there - it looks in either server/all/deploy or server/default/deploy. Does this make sense?

                                  Is there a way around this problem as I do want to install a specifically-named configuration?

                                  Thanks.

                                  (I'm running JBoss Eclipse IDE 2.0.0.Beta1 and JBoss 4.0.5)