0 Replies Latest reply on Dec 4, 2006 4:34 PM by Charlie Kelly

    Can't Launch from Windows to Linux

    Charlie Kelly Newbie

      I'm using JBoss IDE 1.6.0 on a windows XP platform;
      JBoss 4.0.4.GA is on a Linux platform

      JBoss AS on Linux starts fine from the Linux shell prompt, but not from JBoss IDE. I get the following on the console within JBoss IDE

      14:20:37,569 INFO [Server] Starting JBoss (MX MicroKernel)...
      14:20:37,569 INFO [Server] Release ID: JBoss [Zion] 4.0.4.GA (build: CVSTag=JBoss_4_0_4_GA date=200605151000)
      14:20:37,579 INFO [Server] Home Dir: \\192.168.1.5\jboss\jboss-4.0.4.GA
      14:20:37,589 INFO [Server] Home URL: file://192.168.1.5/jboss/jboss-4.0.4.GA/
      14:20:37,589 INFO [Server] Patch URL: null
      14:20:37,589 INFO [Server] Server Name: default
      14:20:37,589 INFO [Server] Server Home Dir: \\192.168.1.5\jboss\jboss-4.0.4.GA\server\default
      14:20:37,589 INFO [Server] Server Home URL: file://192.168.1.5/jboss/jboss-4.0.4.GA/server/default/
      14:20:37,589 INFO [Server] Server Log Dir: \\192.168.1.5\jboss\jboss-4.0.4.GA\server\default\log
      14:20:37,589 INFO [Server] Server Temp Dir: \\192.168.1.5\jboss\jboss-4.0.4.GA\server\default\tmp
      14:20:37,599 INFO [Server] Root Deployment Filename: jboss-service.xml
      14:20:38,040 INFO [ServerInfo] Java version: 1.5.0_02,Sun Microsystems Inc.
      14:20:38,050 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.5.0_02-b09,Sun Microsystems Inc.
      14:20:38,050 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
      14:20:38,441 INFO [Server] Core system initialized
      Failed to boot JBoss:
      org.jboss.deployment.DeploymentException: url file://192.168.1.5/jboss/jboss-4.0.4.GA/server/default/conf/jboss-service.xml could not be opened, does it exist?
      at org.jboss.deployment.DeploymentInfo.(DeploymentInfo.java:211)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:770)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:755)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
      at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
      at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
      at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
      at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
      at $Proxy5.deploy(Unknown Source)14:20:38,491 INFO [Server] Runtime shutdown hook called, forceHalt: true
      14:20:38,491 INFO [Server] JBoss SHUTDOWN: Undeploying all packages


      The jboss-service.xml file does exist and its access mode is set (temporarily) to 777

      I'll appreciate any suggestions or help.

      Thanks

      Charlie