0 Replies Latest reply on Feb 10, 2007 12:56 PM by Arnie Morein

    Strange Behavior on OS X 10.4.8

    Arnie Morein Novice

      Running Eclispe 3.2.1, Build id: M20060921-0945. JBoss IDE 1.6.0.GA. JBoss is installed under /usr/local/jboss/jbossStnd (I have different versions). I own and have full rights to the folders. Java 1.5.0.6-64

      Working on a JSF/JBoss application. Program compiles and deploys. Server object is a JBOSS 4.0 object. When the IDE starts server (regular or debug mode), the log shows the JBoss server gets to about point where Web Services are starting when it suddenly starts shutting down. The IDE shows no errors, just that the server shutdown. JBoss log shows errors I've never seen before and I cannot find any answers to. This same JBoss setup and war runs just fine if started from the command line.

      One thing I've noticed is that the JBOSS 4.0 server object in Eclipse appears to be read-only. I cannot make any changes to it whatsoever. No errors, just no * in the filename tab and any changes via the IDE are discarded.

      Partial Log

      2007-02-10 11:41:55,720 DEBUG [org.jboss.deployment.scanner.URLDeploymentScanner] Unable to obtain watchUrl from deployer. Use url: file:/usr/local/jboss/jbossStnd/server/default/deploy/security.sar/
      java.lang.NullPointerException
       at org.jboss.deployment.scanner.AbstractDeploymentScanner.getDeployer(AbstractDeploymentScanner.java:88)
       at org.jboss.deployment.scanner.URLDeploymentScanner$DeployedURL.getLastModified(URLDeploymentScanner.java:762)
       at org.jboss.deployment.scanner.URLDeploymentScanner$DeployedURL.deployed(URLDeploymentScanner.java:734)
       at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:432)
       at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:634)