1 Reply Latest reply on Apr 4, 2007 3:18 PM by Dilip Maddi

    Cant find JBoss 3.2.x in the debug configurations

    Sam Lam Newbie

      Hi all,

      I installed 2.0.0.Beta2 (JBossIDE-2.0.0.Beta2-Bundle-win32.zip). I follow the tutorial and everything is fine until I reach Chapter 10 - JBoss Configuration and Launch. The problem is that I cannot find the JBoss 3.2.x in the left tree panel. What's wrong?

      Please help! Thanks!

      Lam

        • 1. Re: Cant find JBoss 3.2.x in the debug configurations
          Dilip Maddi Newbie

          There is nothing wrong with the IDE, the tutorial is not udpated for the latest IDE release.

          If you are facing problems to create a server and deploy the app you can check out the below steps.

          Creating a server configuration for first time
          --------------------------------
          1. Click on JBoss AS icon OR switch to JBoss AS perspective.
          2. Click on New server
          3. Select JBoss Inc/JBoss AS 4.0(if you are creation version 4.x server),
          and enter the server name(default is localhost) and click Next
          4. Enter the name for the runtime to be used for the server, the home directory for the server.
          Select the default configuration after entering the details and click Next
          (A successful runtime is created which can be used by mulitple server's)
          5. Enter the server name and click Next
          6. Click Finish and test the server by starting it.

          Deploying the Application on server
          -----------------------------------
          1. Select the ear(FiboApp.ear) file instead of project(Tutorial) and right click, select Run As/Run on Server
          2. You can select the server created in previous step and click Next.
          3. You can see the ear file on RHS and cick Finish to deploy it on server.
          4. Access the deployed app i.e http://localhost:8080/fibo/