2 Replies Latest reply on Mar 17, 2008 7:10 AM by Sheela T

    JDWP unable to get necessary JVMTI capabilities

    Joe Nguyen Newbie

      Jboss AS 4.03 SP1 Running on Linux
      Eclipse 3.1.2 running on XP

      Though I could remotely debug jboss AS which ran on my window, I could not debug when Jboss AS ran on Linux. First, I modified the wrapper.conf to specify additional parameter as
      ...
      wrapper.java.additional.4=-Xdebug -Xrunjdwp:server=y,transport=dt_socket,address=4142,suspend=n

      wrapper.debug=true
      ....
      After jboss app server had started, I tried but could not establish connection to the remote AS from Eclipse remote java application. I searched and could not find '4142' in the server.log.

      On the second attempt, I tried to start jboss by run.sh script. I modified this file to add
      ...
      JAVA_OPTS="$JAVA_OPTS -Xdebug -Xrunjdwp:server=y,transport=dt_socket,address=4142,suspend=n"
      ....
      I restarted jboss AS and got this exception.

      JDWP unable to get necessary JVMTI capabilities

      From google, I knew this error occured in jdk 5.0.1, but my jdk is 5.0.6.
      Since my jdk version on window is the same as the one on Linux and I have been successfully remotely debug AS on window, I don't think jdk could be an issue.

      Have any one successfully remote debug on Linux using jdk 1.5?