2 Replies Latest reply on Jul 9, 2007 7:02 PM by Bernhard Hurzeler

    Wrong dependancy on  JBossIDE JBossAS Adapter Feature (1.0.0

    Bernhard Hurzeler Novice

      I just noticed that the nighly build insists on wst 1.1.0 (under software updates). Does anyone know how to get around this? It prevents me from installing other plugins.

      JBossIDE JBossAS Adapter Feature (1.0.0.200707031655-nightly) requires plug-in "org.eclipse.wst.common.project.facet.core (1.1.0)", or equivalent.


        • 1. Re: Wrong dependancy on  JBossIDE JBossAS Adapter Feature (1
          Rauan Maemirov Newbie

          Hi! Actually I posted topic like this. There is also JIRA to it.

          Yesterday I've found some cunny solutions.

          At first install all required plugins through Update Manager (such as Spring IDE, Subclipse or Maven).

          And only after then install JBossTools or TPTP(it's also buggy despite of release. it requires eclipse sdk and main Europa download doesn't satisfy it).
          When U're installing this plugins, don't unzip it to the main folder. Create another extension locations. I've created directory extensions in eclipse. So,

          eclipse
          -----features
          -----plugins
          -----extensions
          ----------JbossTools
          ---------------eclipse
          --------------------.eclipseextension
          --------------------features
          --------------------plugins


          Write in .eclipseextension file this:

          id=org.eclipse.platform
          name=Eclipse Platform
          version=3.3.0
          


          Then in Manage Configuration add this location.

          But, anyway, after this, U still cannot install stuff through Update Manager. :(

          • 2. Re: Wrong dependancy on  JBossIDE JBossAS Adapter Feature (1
            Bernhard Hurzeler Novice

            Hi, I think your solution gives you an easy way to install new nightly builds but does not fix the dependency issue unfortunately.