10 Replies Latest reply on Oct 8, 2007 10:29 AM by Max Rydahl Andersen

    Seam 2.0

    Newbie

      Hi,

      Is is possible to reconfigure jboss tools to use jboss seam 2.0.0.CR1.

      I have it working fine with 1.2 but if I add a 2.0 to the seam configuration screen in the preferences, I cannot select it from the seam project wizard.

      Thanks,

      Richard

        • 1. Re: Seam 2.0
          Max Rydahl Andersen Master

          Everything but the project creation wizards will/should work with Seam 2.

          For now the project creation wizards only targets Seam 1.2.

          • 2. Re: Seam 2.0
            Thorsten Kunz Novice

            Will this be in beta4 or is there a JIRA task for that that I missed when looking for it?

            • 3. Re: Seam 2.0
              Max Rydahl Andersen Master

              it did not make it into b4; there is a couple of jira's that relates to seam 2 support (a search for 'seam 2' should reveal them)

              • 4. Re: Seam 2.0
                Martin Weigel Newbie

                Is Seam 2.0 support planned anytime soon (CR1)? Seam 2.0 GA is just around the corner and project creation is particulary interesting with that one as most people want to play around with 2.0 once it is out. At the moment it is not very easy to quickly create a running 2.0 demo out of eclipse. Anyway, thanks for your work.

                • 5. Re: Seam 2.0
                  Max Rydahl Andersen Master

                  I don't want to promise anything I can't hold; so I can only tell you at the moment that it is also on my top wishlist.

                  • 6. Re: Seam 2.0
                    Martin Weigel Newbie

                    I just realized, that in the newer nightlys it is no longer possible to install runtimes newer than 1.2.1. Maybe this could be fixed first as it is very annoying when trying out 2.0. Or do you want to leave 2.0 generally out until you officially support it?

                    • 7. Re: Seam 2.0
                      Max Rydahl Andersen Master

                      runtimes are currently only used by the wizards and the wizards will fail against a 2.0 dir layout since its different thatn 1.2 (plus the test/embeddedejb setup is different)

                      Thus we added a strict check for this release.

                      Yes, it sucks and yes its on the top of my wishist.

                      • 8. Re: Seam 2.0
                        Martin Weigel Newbie

                        No, it does not suck. Well at least not if you know where to change it. ;) For those, who want to play around with it: I just changed the path under \workspace\.metadata\.plugins\org.eclipse.core.runtime\.settings\D:\workspace\.metadata\.plugins\org.eclipse.core.runtime\.settings and now it continues to work (somehow) with CR2. Of course that does not make the Tools Seam 2.0 compatible. Anyway, thanks for your work to Max and the whole team.

                        • 9. Re: Seam 2.0
                          Martin Weigel Newbie

                          Hmm, no edit function here. Anyway, I just realize that it does not make sense to manually change that in the preferences. I thought eclipse would load the seam libraries from the runtime location when deploying. But if I understood you right, this has nothing to do with the runtime setting. So I have to switch to the new libraries in the build path. Sorry for my noobity. ;)

                          • 10. Re: Seam 2.0
                            Max Rydahl Andersen Master

                            Yes - the runtime's are currently "just" used for geting the various files needed for the projects.

                            Everything is copied.

                            And for stuff that needs templates we read from thes seam-gen in the pointed to runtime.