2 Replies Latest reply on Oct 8, 2007 2:18 PM by Geoff Hart

    Imported Eclipse projects won't build

    Geoff Hart Newbie

      I had been running JBoss IDE for Eclipse 2.0.0.Beta2 with 3 JBossAS projects which compiled and worked fine.

      When I imported these projects into RHDS Beta2, the projects seem to import fine and I can't find any missing/broken links. However, I can't build any of the projects anymore - nothing fails, the options are simply grayed out.

      I have no idea what to do now - there's no errors, and nothing appears to fail - the option to build the project is simply disabled. Can anyone help?

        • 1. Re: Imported Eclipse projects won't build
          Max Rydahl Andersen Master

          what does the error log say ?

          I've never seen the build button be greyed out (unless build automatically is enabled)

          • 2. Re: Imported Eclipse projects won't build
            Geoff Hart Newbie

            Good call! If I disable auto-build, then I can manually build the projects.

            Looking at it more carefully now though, I see that I was just mis-interpretting the problem. It is building the project (in that it generates all the .class files), but it doesn't run the packaging at the end. Since it wasn't producing the final .war/.jar files, I assumed it wasn't building; but it turns out it's just not packaging.

            When I clean all and build, the first, and most suspicious error it comes up with is this:

            Skipping builder 'org.jboss.ide.eclipse.packaging.core.PackagingBuilder' for project 'Web Common'. Either the builder is missing from the install, or it belongs to a project nature that is missing or disabled.

            ... and it's right, that package doesn't exist; but I'm not sure what it expects me to do about that? I tried deleting and re-creating the workspace, and then cleaning and rebuilding all the projects - which changed nothing.

            Is packaging supposed to be configured differently in this version?