13 Replies Latest reply on Nov 23, 2007 8:15 AM by Max Rydahl Andersen

    new "Seam Web Project" > "Target Runtime" unavailable or bro

    Nathan Clark Newbie

      Hi all,
      for some reason when I try to create a new seam web project, the target runtime will not work properly. I have more then one Server runtime created (tomcat and jboss) yet when I click the "target runtime" drop down all I see is , unable to select my existing servers.

      I tried to click the "new" icon and create a new server, however once I finish that flow and am returned to were I started, the new server is still unavailable.

      any suggestions?

        • 1. Re: new
          Max Rydahl Andersen Master

          you need to use the JBoss adapter done by us - for now the seam facet is only supported by this runtime.

          we will work on getting it to run on the other runtime adapters too.

          • 2. Re: new
            Guido Scalise Newbie

             

            "max.andersen@jboss.com" wrote:
            you need to use the JBoss adapter done by us - for now the seam facet is only supported by this runtime.

            we will work on getting it to run on the other runtime adapters too.


            Max, I've just updated to CR1 and I'm having the same problem. I've tried all kinds of server and runtime definitions and still no Server/Runtime appears.

            How can I ensure I'm using the correct adapter?

            Kind Regards,
            Guido Scalise

            • 3. Re: new
              Jan Paul Stegeman Newbie

              Hi,

              I had the same problem. What I did was to "JBoss, a division of Red Hat" as the provider for the adapter, and not "JBoss", which is the default one provided by Eclipse. After that you can select the JBoss runtime that you want, and it will magically show up in the "Target runtime" when you create a new project.


              JP

              • 4. Re: new
                Guido Scalise Newbie

                 

                "elidon" wrote:
                Hi,

                I had the same problem. What I did was to "JBoss, a division of Red Hat" as the provider for the adapter, and not "JBoss", which is the default one provided by Eclipse. After that you can select the JBoss runtime that you want, and it will magically show up in the "Target runtime" when you create a new project.


                JP


                Still a no-go for me... creating a new runtime does nothing... i mean, i still get no new server in the combo after returning from the wizard. Creating a new server (based on the RH adapter) selects a blank item to the combo, but after clicking on the drop-down, I can only select as an option.
                Closing the wizard and opening it again does nothing, either.

                I'd gladly appreciate some help from the JB-IDE team on this issue...

                Guido

                • 5. Re: new
                  Max Rydahl Andersen Master

                  That sounds very weird since using the rh adapter is exactly what should be done....

                  could you try and use jinq to record what you do and share the link here ? (http://blog.xam.dk/archives/83-Jinq-the-best-tool-for-reporting-bugs-for-any-UI!.html)

                  • 6. Re: new
                    Guido Scalise Newbie

                     

                    "max.andersen@jboss.com" wrote:
                    That sounds very weird since using the rh adapter is exactly what should be done....

                    could you try and use jinq to record what you do and share the link here ? (http://blog.xam.dk/archives/83-Jinq-the-best-tool-for-reporting-bugs-for-any-UI!.html)


                    Max, I'll make the screencast and let you know as soon as I have it.
                    OTOH, we are pretty experienced in PDE/Plugin/RCP development. I'd be glad to help on finding and fixing the bug, what do I need to do to get developer/commiter status?

                    Kind regards,
                    Guido Scalise

                    • 7. Re: new
                      Max Rydahl Andersen Master

                      checkout stuff from svn, do some good patches and attach them to jira - then people tend to get access :)

                      • 8. Re: new
                        David Binder Newbie

                         


                        we will work on getting it to run on the other runtime adapters too.


                        Is it planned for GA ?

                        David

                        • 9. Re: new
                          Max Rydahl Andersen Master

                          nightly builds does not limit the possible runtime and servers to our adapter any more - now we only require that the adapter says it supports the reelvant JEE5 related specs for WAR and/or EAR.

                          Of course we can't guarantee it will actually deploy/compile on others since we no longer controls what libraries the runtime and the server provides.

                          That is something you can adjust when the project is created.

                          Would love to get feedback from what libraries etc. you needed to setup for the various JEE5 runtimes to deploy it. then we can work on getting that handled in later revisions.

                          • 10. Re: new
                            Guido Scalise Newbie

                            Max,
                            you can get the screencast here: http://screencast.com/t/iXwXVgqiazF

                            It was done on just-installed copies of both RHDevStudio (with the included server) and JBoss 4.0.5.GA (Jems installer 1.2.0.GA and EJB3 profile). The JRE of RHDS and JBServer is jre1.5.0_13.

                            As you can see, the server is correctly created, but for some reason, it doesn't appear in the drop down, not even after closing the wizard and opening it again.

                            Guido

                            • 11. Re: new
                              David Binder Newbie

                               

                              nightly builds does not limit the possible runtime and servers to our adapter any more - now we only require that the adapter says it supports the reelvant JEE5 related specs for WAR and/or EAR.


                              Does seam plugin provide project creation for tomcat/hibernate (which is no J2EE) using the right configuration files (datasource, micro container ...) for the right seam version.

                              David

                              • 12. Re: new
                                Max Rydahl Andersen Master

                                no, we haven't done anything specifically for this configuration.

                                But I don't see any issue in you just using the WAR project we create and adjust it accordingly.

                                Let us know how much work/doesn't work if you try it ;)

                                • 13. Re: new
                                  Max Rydahl Andersen Master

                                  hi gscalise,

                                  I thought we had both 4.0 and 4.2 marked as compatible with the seam facet - but apparently something is missing...maybe the jst.web are not in sync.

                                  anyhow - there is no technical difference between using 4.2 adapter for a 4.0.5 runtime so as a workaround use the 4.2 adapter and point to 4.0.5.

                                  p.s. in nightly build this should work - let us know if it doesn't.