4 Replies Latest reply on Nov 19, 2007 3:19 PM by Marcus Adair

    "Error copying file" during publish (RHDS CR1, JBAS 4.2.2, S

    Marcus Adair Newbie

      I'm getting the following error for each of the publishable files in an EAR-style project set when I publish:



      eclipse.buildId=unknown
      java.version=1.6.0_03
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86
      
      Error
      Mon Nov 19 11:59:58 MST 2007
      Error copying file: C:\jboss-4.2.2.GA\server\default\deploy\spades-ear.ear\spades-ejb.jar\META-INF\ejb-jar.xml to META-INF\ejb-jar.xml
      
      java.io.IOException: The system cannot find the path specified
      at java.io.WinNTFileSystem.createFileExclusively(Native Method)
      at java.io.File.checkAndCreate(Unknown Source)
      at java.io.File.createTempFile(Unknown Source)
      at org.jboss.ide.eclipse.as.core.server.xpl.PublishUtil.copyFile(PublishUtil.java:98)
      at org.jboss.ide.eclipse.as.core.server.xpl.PublishUtil.copyFile(PublishUtil.java:450)
      at org.jboss.ide.eclipse.as.core.server.xpl.PublishUtil.copy(PublishUtil.java:505)
      at org.jboss.ide.eclipse.as.core.server.xpl.PublishUtil.publishFull(PublishUtil.java:481)
      at org.jboss.ide.eclipse.as.core.server.xpl.PublishUtil.copy(PublishUtil.java:496)
      at org.jboss.ide.eclipse.as.core.server.xpl.PublishUtil.publishFull(PublishUtil.java:481)
      at org.jboss.ide.eclipse.as.core.publishers.JstPublisher.fullPublish(JstPublisher.java:129)
      at org.jboss.ide.eclipse.as.core.publishers.JstPublisher.publishModule(JstPublisher.java:111)
      at org.jboss.ide.eclipse.as.core.server.internal.DeployableServerBehavior.publishModule(DeployableServerBehavior.java:130)
      at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publishModule(ServerBehaviourDelegate.java:749)
      at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publishModules(ServerBehaviourDelegate.java:835)
      at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(ServerBehaviourDelegate.java:669)
      at org.eclipse.wst.server.core.internal.Server.doPublish(Server.java:887)
      at org.eclipse.wst.server.core.internal.Server.publish(Server.java:874)
      at org.eclipse.wst.server.core.internal.PublishServerJob.run(PublishServerJob.java:72)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
      
      


      Besides that error for each file, Eclipse doesn't seem to report any other errors.

      I'm using the Red Hat Developer Studio CR1 install. The project is vanilla, create by the Seam tool within Eclipse. I have plenty of disk space.

      The projects deployed properly at first, I then imported them into a fresh Eclipse workspace directory, and as near as I can tell that was when this started. I don't have the old workspace around to try moving them back.

      I have now tried creating a fresh project and am getting exactly the same result. I can't think of any other change of any significance that I have made to my system.

      Any ideas will be greatly appreciated?