6 Replies Latest reply on Dec 6, 2007 2:13 AM by Fadil Wiranata

    Hibernate Tools dependency?

    Fadil Wiranata Newbie

      Hi..
      Is it possible to just install Hibernate Tools instead of the whole package of JBoss Tools in Eclipse 3.3.1? What are the requirement to install Hibernate Tools only? I tried to installed it but getting error log when changing to Hibernate perspective.
      Thanks.. :)

        • 1. Re: Hibernate Tools dependency?
          Fadil Wiranata Newbie

          I tried to install the whole package. Heres what I get :
          Am I missing something? Thanks..

          !SESSION 2007-12-06 08:49:02.546 -----------------------------------------------
          eclipse.buildId=M20071023-1652
          java.version=1.6.0_03
          java.vendor=Sun Microsystems Inc.
          BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
          Command-line arguments: -os win32 -ws win32 -arch x86
          
          !ENTRY org.eclipse.osgi 2 0 2007-12-06 08:49:15.937
          !MESSAGE While loading class "org.eclipse.mylyn.internal.tasks.ui.WorkspaceAwareContextStore", thread "Thread[main,6,main]" timed out waiting (5000ms) for thread "Thread[Worker-1,5,main]" to finish starting bundle "update@plugins/org.eclipse.mylyn.tasks.ui_2.1.0.v20070927-0900.jar [363]". To avoid deadlock, thread "Thread[main,6,main]" is proceeding but "org.eclipse.mylyn.internal.tasks.ui.WorkspaceAwareContextStore" may not be fully initialized.
          !STACK 0
          org.osgi.framework.BundleException: State change in progress for bundle "update@plugins/org.eclipse.mylyn.tasks.ui_2.1.0.v20070927-0900.jar" by thread "Worker-1".
           at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1141)
           at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:258)
           at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400)
           at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
           at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:417)
           at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
           at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340)
           at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:408)
           at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
           at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
           at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
           at java.lang.ClassLoader.loadClass(Unknown Source)
           at org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:289)
           at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)
           at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1269)
           at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160)
           at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:788)
           at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
           at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
           at org.eclipse.mylyn.context.core.ContextCorePlugin$ContextStoreExtensionReader.readStore(ContextCorePlugin.java:282)
           at org.eclipse.mylyn.context.core.ContextCorePlugin$ContextStoreExtensionReader.initExtensions(ContextCorePlugin.java:271)
           at org.eclipse.mylyn.context.core.ContextCorePlugin.getContextStore(ContextCorePlugin.java:242)
           at org.eclipse.mylyn.internal.context.core.InteractionContextManager.loadActivityMetaContext(InteractionContextManager.java:138)
           at org.eclipse.mylyn.internal.context.core.InteractionContextManager.getActivityMetaContext(InteractionContextManager.java:132)
           at org.eclipse.mylyn.internal.context.core.InteractionContextManager.processActivityMetaContextEvent(InteractionContextManager.java:177)
           at org.eclipse.mylyn.internal.monitor.ui.ShellLifecycleListener.<init>(ShellLifecycleListener.java:35)
           at org.eclipse.mylyn.monitor.ui.MonitorUiPlugin$2.run(MonitorUiPlugin.java:110)
           at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
           at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
           at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3659)
           at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3296)
           at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2389)
           at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
           at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2219)
           at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
           at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:289)
           at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:461)
           at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
           at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:106)
           at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)
           at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
           at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
           at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
           at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
           at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
           at java.lang.reflect.Method.invoke(Unknown Source)
           at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
           at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
           at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
          Caused by: org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
           ... 51 more
          Root exception:
          org.eclipse.osgi.framework.internal.core.AbstractBundle$BundleStatusException
           at org.eclipse.osgi.framework.internal.core.AbstractBundle.beginStateChange(AbstractBundle.java:1141)
           at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:258)
           at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400)
           at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
           at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:417)
           at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
           at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340)
           at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:408)
           at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
           at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
           at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
           at java.lang.ClassLoader.loadClass(Unknown Source)
           at org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:289)
           at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)
           at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1269)
           at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160)
           at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:788)
           at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
           at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
           at org.eclipse.mylyn.context.core.ContextCorePlugin$ContextStoreExtensionReader.readStore(ContextCorePlugin.java:282)
           at org.eclipse.mylyn.context.core.ContextCorePlugin$ContextStoreExtensionReader.initExtensions(ContextCorePlugin.java:271)
           at org.eclipse.mylyn.context.core.ContextCorePlugin.getContextStore(ContextCorePlugin.java:242)
           at org.eclipse.mylyn.internal.context.core.InteractionContextManager.loadActivityMetaContext(InteractionContextManager.java:138)
           at org.eclipse.mylyn.internal.context.core.InteractionContextManager.getActivityMetaContext(InteractionContextManager.java:132)
           at org.eclipse.mylyn.internal.context.core.InteractionContextManager.processActivityMetaContextEvent(InteractionContextManager.java:177)
           at org.eclipse.mylyn.internal.monitor.ui.ShellLifecycleListener.<init>(ShellLifecycleListener.java:35)
           at org.eclipse.mylyn.monitor.ui.MonitorUiPlugin$2.run(MonitorUiPlugin.java:110)
           at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
           at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
           at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3659)
           at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3296)
           at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2389)
           at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
           at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2219)
           at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
           at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:289)
           at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:461)
           at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
           at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:106)
           at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)
           at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
           at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
           at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
           at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
           at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
           at java.lang.reflect.Method.invoke(Unknown Source)
           at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
           at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
           at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
          


          • 2. Re: Hibernate Tools dependency?
            Max Rydahl Andersen Master

            you keep posting stacktraces about mylyn...that has nothing todo with WTP nor Hibernate.

            • 3. Re: Hibernate Tools dependency?
              Max Rydahl Andersen Master

              there are nothing in that stacktrace related to hibernate.

              The hibernate bundle just requires WTP, nothing else it is intended and it is standalone.

              • 4. Re: Hibernate Tools dependency?
                Fadil Wiranata Newbie

                I read the installation manual and it says to use Java 5. So i revert back to JDK 5 and Eclipse EE 3.3.1 with WTP 2.0.1 ( fresh install ), but still having error log when switch to Hibernate Perspective. Does anybody successfully install 2.0.0.RC1 on Eclipse? Please help.. Thank you..

                • 5. Re: Hibernate Tools dependency?
                  Max Rydahl Andersen Master

                  you still haven't shown me something that is related to hibernate not working....

                  • 6. Re: Hibernate Tools dependency?
                    Fadil Wiranata Newbie

                    Sorry Max, I guess we posted at the same time. :) So you're saying that I can just ignore the error log? Okay then.. Will do.
                    Btw, normal Eclipse distributes with Mylyn bundled in it. I will try to download the classic version. And start from there.
                    Thanks for helping.