13 Replies Latest reply on Mar 9, 2008 6:38 PM by Tony Herstell

    MyEclipse cannot install JBoss Tools

    Tony Herstell Master

      I get this error:

      JBossAS Tools (1.0.0.GA) requires plug-in "org.eclipse.wst.server.ui.doc.user".



      I try not to include the AS tools (as the MyEclipse ones seem ok) and I get:

      SeamTools Feature (2.0.0.GA) requires feature "org.jboss.ide.eclipse.as.feature".


      It would be nice to evaluate this set of tools as I use Seam almost daily; if you can explain how I fix this that would be great.

      Thx.

        • 1. Re: MyEclipse cannot install JBoss Tools
          Rob Stryker Master

          Unfortunately, the seam plugins currently depend on the JBoss AS Tools. The specific portion the seam plugins depend on is the ability to deploy a single file using WTP API's (standard APIs).

          The problem here is that the ability to turn a single file into a "module" and publish it upon project creation (specifically the datasource) is not a standard part of WTP and is an extension only the JBoss Tools AS-Tools plugin provides. The Seam plugin makes use of this.

          • 2. Re: MyEclipse cannot install JBoss Tools
            Tony Herstell Master

             

            "rob.stryker@jboss.com" wrote:
            Unfortunately, the seam plugins currently depend on the JBoss AS Tools. The specific portion the seam plugins depend on is the ability to deploy a single file using WTP API's (standard APIs).

            The problem here is that the ability to turn a single file into a "module" and publish it upon project creation (specifically the datasource) is not a standard part of WTP and is an extension only the JBoss Tools AS-Tools plugin provides. The Seam plugin makes use of this.


            Thanks for your reply Rob,

            Humm not that I really know what you mean but I have had Seam working in MyEclipse using exploded deployment for well over a year... (i.e. NO ANT for over a year!)

            I create three projects EAR, Jar and War... (the MyEclipse wizard now actually helps with this since the EJB3 stuff was added a few months ago). I Link these together to for an Ear deployment.

            I dont what everyones hangup was about having ONE file... works fine having the three for me and so what ifI have three "prjects" in CM... e.g. (current "project" is Sec, SecEJB, SecWeb).

            I have to turn off a lot of helpers from MyEclipse (like keeping the EAR application.xml up to date as its messes up the Seam application.xml you carefully create).

            Then I just "deploy" the Ear, in MyEclipse, as exploded and start the server (from the MyEclipse Run/Stop/Re-Start MyEclipse server button).

            If I can run quite well without a single module why do the tools depend on a single module?

            Assuming I don't give a rats ass about the deployment helper tools (as MyEclipse ones work fine) but still want the little nice windows'ey type stuff like the Seam file wizards; .xhtml viewer (with decent EL support) then is it possible to give me the seam tool's without the AS bits... I have had to live without EL completion for over a year; and it would be nice!

            After all; Seam tools should not mean JBoss AS tools should it?

            ??

            • 3. Re: MyEclipse cannot install JBoss Tools
              Tony Herstell Master

              I don't even care about project creation!

              :)

              • 4. Re: MyEclipse cannot install JBoss Tools
                Max Rydahl Andersen Master

                And why is adding the jboss as plugin an issue ?
                Does that not work ?

                Seam Tools would require WTP anyway so this first missing requirment it not really the issue...

                • 5. Re: MyEclipse cannot install JBoss Tools
                  Tony Herstell Master

                  MyEclipse already support JBoss server through its own tools so to start/stop the server is already supported.

                  I just wanted the Seam and RichFaces tools for completion support and better view of the Seam "config" files etc.

                  Pressing ctrl-space when using Seam and RF tags in .xhtml would be so nice.

                  • 6. Re: MyEclipse cannot install JBoss Tools
                    Rob Stryker Master

                    the best we could do, I imagine, is to try to separate the editor out from WTP API's... but I'm not sure this would even be a priority at all at this time.

                    • 7. Re: MyEclipse cannot install JBoss Tools
                      Tony Herstell Master

                      I understand that it's not a priority.
                      I "manage" as I have both the Seam Manual and RichFaces Manual (PDF) open and flick between them all the time.
                      If you do ever re-factor things then please don't forget this request.
                      You never know; the MyEclipse guys may even offer to help with the split.. after all their tool takes the best of breed of all the plugins (and enhances some even more) and that's what makes MyEclipse what it is!
                      Thanks anyhow.

                      • 8. Re: MyEclipse cannot install JBoss Tools
                        Max Rydahl Andersen Master

                        if myeclipse wants to come and contribute they would be welcome.

                        But until then what does it hurt to add that .as plugin to myeclipse ?

                        • 9. Re: MyEclipse cannot install JBoss Tools
                          Tony Herstell Master

                           

                          "max.andersen@jboss.com" wrote:
                          if myeclipse wants to come and contribute they would be welcome.

                          But until then what does it hurt to add that .as plugin to myeclipse ?


                          Ok, I assumed that it would mess up myEclipse as it has its own ability to run the server and do exploded deployment... I will install a clean MyEclipse and add in the JBoss "pack" and see if it works.

                          Worth a look I suppose.

                          • 10. Re: MyEclipse cannot install JBoss Tools
                            Tony Herstell Master

                            I have tried...

                            Can't install them into MyEclipse.

                            JBossAS Tools (1.0.0.GA) requires plug-in "org.eclipse.wst.server.ui.doc.user".

                            If I unlick the JBossAS (as I don't need it) the Seam tools complain as they need them:

                            SeamTools Feature (2.0.0.GA) requires feature "org.jboss.ide.eclipse.as.feature".

                            • 11. Re: MyEclipse cannot install JBoss Tools
                              Tony Herstell Master

                              Just selecting RichFaces gives this error:

                              Update operation has failed
                              Error retrieving the plug-in entry: "org.mozilla.xpcom_1.8.1.3-20070904". [The file "/C:/MyEclipse JBoss Plugins/eclipse/plugins/org.mozilla.xpcom_1.8.1.3-20070904.jar" does not exist.]
                              The file "/C:/MyEclipse JBoss Plugins/eclipse/plugins/org.mozilla.xpcom_1.8.1.3-20070904.jar" does not exist.

                              • 12. Re: MyEclipse cannot install JBoss Tools
                                Rob Stryker Master

                                The mozilla jars are an interface layer atop binary builds of xulrunner and its dependencies. They're required for the visual editor.

                                • 13. Re: MyEclipse cannot install JBoss Tools
                                  Tony Herstell Master

                                  I am not getting anywhere with this :(

                                  Ill skip using the tools for now and hope MyEclispe and JBoss Tools integrate at some point.

                                  Keep up the good work (as they look really useful).