5 Replies Latest reply on Mar 14, 2008 12:45 PM by Max Rydahl Andersen

    JBoss Tools using Latest Seam

    scott duke Novice

      When will JBoss Tools be updated using the latest Seam version? It looks like it is only using v1.2

      Also, if a project is created using the seam-gen (outside Eclipse), is there a way to let JBoss-Tools know this, in order to use the Seam tools inside Eclipse?

      I am assuming that the project -> properties -> Seam Settings is the place to do this, but once again it uses v1.2 and I created the project using 2.0 seam.

        • 1. Re: JBoss Tools using Latest Seam
          Max Rydahl Andersen Master

          JBoss Tools does not come preconfigured with anything so if it says the runtime is v1.2 then it is because you added it as such.

          You can create an additonal runtime that points to Seam 2.0

          Your assumptions about how to enable support for commandline seamgen'ed app is btw. correct.

          • 2. Re: JBoss Tools using Latest Seam
            Darryl Sibeon Newbie

            Has the problem with Module Dependencies been fixed yet for Seam 2.0.1?? I have to use Seam 2.0.0 to make them work.. I saw a similar problem at the forum on seamframework.org and they say it's a Jboss Tools problem..

            Got an idea when it'll be fixed??

            • 3. Re: JBoss Tools using Latest Seam
              Max Rydahl Andersen Master

               

              "Aaragus" wrote:
              Has the problem with Module Dependencies been fixed yet for Seam 2.0.1?? I have to use Seam 2.0.0 to make them work.. I saw a similar problem at the forum on seamframework.org and they say it's a Jboss Tools problem..


              ...and I say it is a Eclipse Webtools problem ;)

              btw. not sure that question is related to sandman's initial question.


              Got an idea when it'll be fixed??


              See
              http://jira.jboss.com/jira/browse/JBIDE-1716
              for our recording of the issue and see https://bugs.eclipse.org/bugs/show_bug.cgi?id=217666 which is the webtools side of things where we submitted a patch for it.

              If you try and use Webtools 2.0.2 this should be fixed.

              Let us know if it works for you now - it would be much appreciated.

              • 4. Re: JBoss Tools using Latest Seam
                Brahim Haddar Newbie

                Hi there,

                I got an issue (or may be the problem is on my end). I want to use the latest release of Seam (2.1.0.A1 version).

                I'm using JBoss Tools 2.0.0 GA so I tried to add Seam Runtime that points to this version but the drop-down list "Version" shows two values only 1.2 and 2.0

                I went ahead and tried to use 2.0 and it says "selected seam appears to be of an incompatible version" (obviously).

                I'm using Eclipse 3.3.1, JBoss AS 4.2.2 GA, JBoss tools 2.0.0.GA

                I'm doing something wrong?

                Thank you in advance for any help.

                • 5. Re: JBoss Tools using Latest Seam
                  Max Rydahl Andersen Master

                  use the forum search on how to workaround it.

                  (or use jboss tools 2.0.1.GA which will be announced soon)