12 Replies Latest reply on May 17, 2008 1:25 AM by Max Rydahl Andersen

    JBoss Tools/App Server/Eclipse/Java  versions. Getting thing

    Jeremy Flowers Newbie

      Hi folks.

      I'm interested in learning more about Hibernate and JBoss Tools.
      I'm in the process of reading Christian & Gavins excellent Java Persistence with Hibernate and trying to set up JBoss Tools in Eclipse..

      In the past I've installed Eclipse Europa edition file:
      eclipse-jee-europa-winter-win32.zip

      Eclipse Platform
      Version: 3.3.2
      Build id: M20080221-1800

      and JBoss 4.2.2GA.

      Selecting JBoss 4.2 in Eclipse never seemed to work....

      I don't know if there is something about the Java version I used that was causing problems, but I could never get Eclipse to detect either JBoss Server (or Glassfish)
      Menu navigation in Eclipse:

      Window->
      Preferences->
      Server->
      Installed Runtimes->
      Search
      

      See here:
      http://dev.eclipse.org/newslists/news.eclipse.newcomer/msg22851.html

      Initial install of Java came from file:
      java_app_platform_sdk-5_04-windows.exe

      Since posting this time I've installed a couple of JRE's too to test applets in browsers, but never heard back from Eclipse forums..
      Java -version now yields:
      java version "1.6.0_05"
      Java(TM) SE Runtime Environment (build 1.6.0_05-b13)
      Java HotSpot(TM) Client VM (build 10.0-b19, mixed mode, sharing)
      


      Now I come on to JBoss Tools.
      I was looking at Hibernate Compatibility matrix here:
      http://www.hibernate.org/6.html
      It indicates that the latest release of Hibernate Core 3.2.6 GA requires 3.2.0 of Tools (rather confusingly labelled, because this relates to Hibernate Tools, not JBoss Tools)..
      Now when I pointed Eclipse to:
      http://download.jboss.org/jbosstools/updates/stable/
      it downloads JBoss Tools 2.0.1.GA..
      If you look here:
      http://sourceforge.net/project/showfiles.php?group_id=22866&package_id=242269&release_id=583838
      you see 2.0.1GA contains Hibernate Tools 3.2.1
      Now this release is "ahead of the curve" with respect to what Hibernate Core 3.2.6GA says it needs. Is this ok? Is backward compatibility assured?
      Only I don't see a more recent version of Hibernate Core!


      (For the folks at Hibernate. It would be a good idea to let us 'newbies' know about all these things and if you scroll down under download tab over at SourceForge you can find the contents of JBoss Tools & versions/archives, sort of like a manifest). I spent ages trying to find this stuff out..

      If you look at (JBoss Tools 2.0.0GA) version here:
      http://sourceforge.net/project/showfiles.php?group_id=22866&package_id=242269&release_id=560787
      This does have corresponding version for Hibernate Core..
      So why does Eclipse update url given above not point to a 2.0.0GA version instead of 2.0.1GA so everything is synchronised?

      Some guidance on what I need to do to properly set Hibernate Eclipse Java and JBoss AS and JBoss Tools all working in conjunction would be most appreciated.

      Many thanks in advance.
      Jeremy