5 Replies Latest reply on Jun 17, 2008 12:59 AM by Max Rydahl Andersen

    Errors testing a simple Seam action with the latest toolset

    Glenn Silverman Newbie

      I'm using SeamTools 2.1.0.GA and get the following error when I try to test (using testNG) a simple action bean created with File->New->Seam Action wizard:

      org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

      *** CONTEXTS IN ERROR: Name -> Error

      SARDeployer -> java.lang.ClassNotFoundException: [Ljava.lang.Class;

      ServiceDeploymentDeployer -> java.lang.ClassNotFoundException: [Ljava.lang.Class;

      ServiceClassLoaderDeployer -> java.lang.ClassNotFoundException: [Ljava.lang.Class;

      BeanDeployer -> java.lang.ClassNotFoundException: [Ljava.lang.Class;

      ServiceDeployer -> java.lang.ClassNotFoundException: [Ljava.lang.Class;

      BeanMetaDataDeployer -> java.lang.ClassNotFoundException: [Ljava.lang.Class;

      KernelDeploymentDeployer -> java.lang.ClassNotFoundException: [Ljava.lang.Class;


      at org.jboss.deployers.plugins.deployers.DeployersImpl.checkComplete(DeployersImpl.java:576)
      at org.jboss.deployers.plugins.main.MainDeployerImpl.checkComplete(MainDeployerImpl.java:559)
      at org.jboss.embedded.Bootstrap.bootstrapURL(Bootstrap.java:149)
      at org.jboss.embedded.Bootstrap.bootstrap(Bootstrap.java:183)
      at org.jboss.embedded.Bootstrap.bootstrap(Bootstrap.java:195)
      at org.jboss.seam.mock.EmbeddedBootstrap.startAndDeployResources(EmbeddedBootstrap.java:11)
      at org.jboss.seam.mock.BaseSeamTest.startJbossEmbeddedIfNecessary(BaseSeamTest.java:1041)
      at org.jboss.seam.mock.BaseSeamTest.startSeam(BaseSeamTest.java:935)
      at org.jboss.seam.mock.BaseSeamTest.init(BaseSeamTest.java:923)
      at org.jboss.seam.mock.SeamTest.init(SeamTest.java:42)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.testng.internal.MethodHelper.invokeMethod(MethodHelper.java:580)
      at org.testng.internal.Invoker.invokeConfigurationMethod(Invoker.java:398)
      at org.testng.internal.Invoker.invokeConfigurations(Invoker.java:145)
      at org.testng.internal.Invoker.invokeConfigurations(Invoker.java:82)
      at org.testng.internal.TestMethodWorker.invokeBeforeClassMethods(TestMethodWorker.java:166)
      at org.testng.internal.TestMethodWorker.run(TestMethodWorker.java:103)
      at org.testng.TestRunner.runWorkers(TestRunner.java:689)
      at org.testng.TestRunner.privateRun(TestRunner.java:566)
      at org.testng.TestRunner.run(TestRunner.java:466)
      at org.testng.SuiteRunner.runTest(SuiteRunner.java:301)
      at org.testng.SuiteRunner.runSequentially(SuiteRunner.java:296)
      at org.testng.SuiteRunner.privateRun(SuiteRunner.java:276)
      at org.testng.SuiteRunner.run(SuiteRunner.java:191)
      at org.testng.TestNG.createAndRunSuiteRunners(TestNG.java:808)
      at org.testng.TestNG.runSuitesLocally(TestNG.java:776)
      at org.testng.TestNG.run(TestNG.java:701)
      at org.testng.remote.RemoteTestNG.run(RemoteTestNG.java:73)
      at org.testng.remote.RemoteTestNG.main(RemoteTestNG.java:124)

      This references an incomplete deployment and "previous errors", but there are none in the TestNG view in Eclipse.

      My testNG configuration is the one created with the File->New->Seam Web Project wizard. I just us the wizards to create the project and an action bean with an action method and run the test without modification. Am I missing something in the configuration?