2 Replies Latest reply on Dec 2, 2008 9:26 AM by Karl Philipp

    [JBoss Tools 2.1.2.GA] Resolving a row variable does not wor

    Karl Philipp Newbie

      Take a look at the following code:

       <rich:dataTable id="cTable" value="#{customers.list}" var="record">
       <rich:column>
       <f:facet name="header"><h:outputText value="Surname" /></f:facet>
       <h:outputText value="#{record.surname}" />
       </rich:column>
       </rich:dataTable>
      


      The row variable named "record" used by the h:outputText element can not be resolved. But if I replace rich:dataTable with h:dataTable the eclipse error "record cannot be resolved" disappers. The deployed project works as expected.

      I use RichFaces Service Release 3.2.2.SR1, Mojarra Release 1.2_10, JBoss Tools 2.1.2.GA, Eclipse 3.4, ...


        • 1. Re: [JBoss Tools 2.1.2.GA] Resolving a row variable does not
          Alexey Kazakov Master

           

          "kphilipp" wrote:
          JBoss Tools 2.1.2.GA, Eclipse 3.4

          Are you sure? JBoss Tools 2.* does not support Eclipse 3.4.
          Anyway I've checked <rich:dataTable> and it works in JBoss Tools 3.0.0 (last nightly build). We have fixed some bugs in var/value resolving since JBoss Tools 2.1.2.GA and now it should works for all tags with "var" and "value" attributes. Please try the latest JBoss Tools 3.0.0 nightly build.

          • 2. Re: [JBoss Tools 2.1.2.GA] Resolving a row variable does not
            Karl Philipp Newbie

             

            "akazakov" wrote:
            Are you sure? JBoss Tools 2.* does not support Eclipse 3.4.
            Anyway I've checked <rich:dataTable> and it works in JBoss Tools 3.0.0 (last nightly build). We have fixed some bugs in var/value resolving since JBoss Tools 2.1.2.GA and now it should works for all tags with "var" and "value" attributes. Please try the latest JBoss Tools 3.0.0 nightly build.


            Well, until last Thursday I used Eclipse 3.3 with the same error in var/value resolving. Then I switched to Eclipse 3.4 without to be aware of the requirements for JBoss Tools 2.1.2.GA.

            I will give JBoss Tools 3.0.0 a try. Thanks.