12 Replies Latest reply on Dec 16, 2008 3:57 PM by Max Rydahl Andersen

    EAR won't deploy to server

    Glenn Tarbox Newbie

      I have the simplest of test cases having been cut it down to 3 or 4 lines of code over the last few days... after being somewhat surprised when stumbling on "no support for 64 bit" afterthought in the forums I got a temporary mental lift... maybe thats it!!!

      So, I did a full redeploy on 32 bit (ubuntu linux). Virgin everything... ganymede j2ee, JBoss Tools from the nightly builds... everything. (BTW, this is jboss-5.0 from svn and I am using the correct server "by Red Hat" seems to be necessary according to other posts somewhere... this can't be a version thing...)

      Thing is I'm able to build and test everything without any difficulty when I manually export an EAR into the deploy directory. And I'm used to eclipse "doing the right thing" when running... but with eclipse and JBoss tools, it just seems to "do nothing".

      It generates the files in the usual obscure hidden within hidden directories (thank you find :-). And I tried changing the server deployment from using the workspace to using the jboss deploy directory... nothin...

      Eclipse simply won't copy the EAR content into the server or do whatever other magic it must use to look into the workspace...

      I'm sure it must work for some folks or there'd be more chatter. Or I'm missing some massive design / use issue which is so obvious I can't see the forest for the trees.

      I'm pretty much at a total loss here. The server starts just fine from scratch (i.e. without any deployed packages)... and looking in the JBoss AS perspective, I can see the EJB and its "synchronized". As there are no other buttons or right click stuff... I figure it should just run.

      no joy here after a couplea days of this.

      Hopefully somebody can point out the simple boneheaded thing I'm doing wrong.

      -glenn

        • 1. Re: EAR won't deploy to server
          Glenn Tarbox Newbie

          Looking inside the highly classified hidden log file inside the hidden metadata directory (eclipse loves hidden directories and files.. maybe someone thought it would save disk space :-)

          Anyway, I'm beginning to see where all the spew is going. apparently, there are a very large number of dependencies which aren't checked by the jboss tools install... including equinox, leading to something in birt... eventually leading to osgi. The required packages aren't part of the eclipse package as downloaded, and google seems not to help much..

          and, the install went without a hitch. at a minimum, it appears as though jboss tools doesn't refer to these requirements so must be part of what the developers use as their baseline... or I might have seen something in the forums... anywhere... unless I'm one of the first non-developers to try and get this to work after the recent releast of AS 5.

          I'll post after I run this down...

          • 2. Re: EAR won't deploy to server
            Glenn Tarbox Newbie

            haven't navigated the eclipse site in a while and had forgotten its breadth... and was immediately reminded of the difficulty of finding plugin urls (perhaps the design team focusing on hidden files and directories is in charge eclipse site navigation...:-)

            Anyway, I put the log dump up at:

            http://www.tarbox.org/eclipse/logspew.bz2

            maybe it will help the next poor soul save a few days.

            As for me, the warm embrace of emacs and seeing something compile and run will be a welcome respite.

            thanks for listening...

            -glenn

            • 3. Re: EAR won't deploy to server
              Max Rydahl Andersen Master

              Hi ghtdak,

              I seriously have a hard time understanding what you are talking about.

              What hidden folders ? You mean the deploy location of servers or ?

              What installer ? There is an updatesite and that should tell you to get the remaining dependencies and not even allow you to install without them.

              Birt is optional so again, do not understand why you point that out as an issue ?

              Would be good if you could pinpoint which issues/error messages you have - then I can much better figure out what to help with ;)

              • 4. Re: EAR won't deploy to server
                Glenn Tarbox Newbie

                I put the entire log output which, I believe, indicates where the unresolved dependencies are in the post to which you replied..

                here it is again:

                http://www.tarbox.org/eclipse/logspew.bz2

                The hidden folders are ~/workspace/.metadata with .log and the subsequent .* directories underneath ~workspace/.metadata. I was unaware of their existence until this problem came up because, while I've been using eclipse for a few years, I've never encountered this kind of problem. Use ls -a in .metadata and an entire eclipse underworld is exposed.

                -glenn

                • 5. Re: EAR won't deploy to server
                  Max Rydahl Andersen Master

                  ghtdak, you still haven't told me what your actual issue is.

                  The logging file just indicates you haven't installed all dependencies.

                  What is the *specific* thing that does not work for you ?

                  • 6. Re: EAR won't deploy to server
                    Max Rydahl Andersen Master

                    btw. Birt et.al. is *not* needed for normal operation so I still need to understand what your actual issue is to help.

                    • 7. Re: EAR won't deploy to server
                      Rob Stryker Master

                      JBoss 5 does not work by default on new servers. I discovered this over the weekend. I've yet to discover a way to add a folder to the deployment scanner.

                      The workaround is after creating a new server, open the server in the server editor by double-clicking the server. Then switch the deploy location to the option of the server's actual deploy folder. "Use the JBoss Deploy Folder".

                      In GA, this will be fixed. Either for 5.0 the default location will be the deploy folder, or I will have discovered how to ensure the .metadata folder is added properly to the list of scannable folders. I was at work on this on Saturday but came up short.

                      • 8. Re: EAR won't deploy to server
                        Glenn Tarbox Newbie

                        Somehow, I've been unsuccessful in communicating. Let me try again

                        1) JBoss doesn't deploy projects.
                        2) It appears as though 1) is caused by package dependencies I haven't installed.

                        max.anderson: While I appreciate that you're trying to help, I suggest you've missed the point on more than one occasion. I realize there are missing dependencies. I think package dependencies are intended to be dependencies of the JBoss tools package (making this a bug report) or in some form of documentation (which isn't the right way to do it, but I'd be satisfied with that as well...).

                        rob.stryker: As I wrote in the original thread, I have tried changing the deploy location and it doesn't work either.

                        restating other previously posted info: under the ~/workspace/.metadata directory the EAR file appears to be constructed. It just never ends up in the deploy directory and, hence, doesn't get run. Or, the default case of having JBoss to look both in the jboss deploy and the .metadata deploy doesn't work either... but rob.stryker points out this might be a current bug... which is fine.

                        I also pointed out this is a virgin install of everything except Java itself. So, this is a BUG unless someone can tell me what I've somehow missed

                        -glenn

                        • 9. Re: EAR won't deploy to server
                          Rob Stryker Master

                          It's a bug. The creation of a JBoss 5 server starts off using the .metadata folder to build the EAR, and later tries to add this folder as a scannable location.

                          It never gets added by JBoss because, unlike older JBoss versions, JBoss 5.0 does not use JMX as much.

                          It's obvious that whatever folder you designate in the editor WILL be the folder the ear is constructed in. The way to solve this problem is to make sure the folder that the server is already scanning (server/default/deploy) is the one where the ear is constructed.

                          This can be done how I said earlier.

                          It is a bug that the JBoss 5.0 server starts off building to .metadata. It shouldnt. It should start off building to server/default/deploy, and I'm fixing that now.

                          • 10. Re: EAR won't deploy to server
                            Max Rydahl Andersen Master

                            ghtdak,

                            The AS functionality clearly does create and EAR but because of the bug Rob is talking about the automatic setup does not work for AS5 GA - it does work for AS4.x.

                            This issue has nothing to do with missing dependencies since if there were missing dependencies related to AS functionality you would not even be able to create or even use the AS view.

                            Hence why I kept saying I wanted you to seperate out your issues so we know what problem you actually had. Sorry if that was not clear.

                            • 11. Re: EAR won't deploy to server
                              Glenn Tarbox Newbie

                              yup, the problem had nothing to do with the dependencies. I managed to minimize my imports to get rid of the dependency errors by only importing the JbossAS package.

                              So, it seems to be working (not my code mind you :-) using the fix proposed.

                              thanks for the help.

                              -glenn

                              • 12. Re: EAR won't deploy to server
                                Max Rydahl Andersen Master

                                Glenn,

                                I tried to reproduce your statement about a lot of dependencies being unresolved but I simply can't reproduce that when I install Eclipse JEE and use the updatesite.

                                Could you tell me which downloads you did specifically and in what sequence ?