2 Replies Latest reply on Apr 3, 2009 10:16 AM by Josh Adams

    'couldn't connect to database' in seam generate entities wit

    Josh Adams Newbie

      I've started playing with jboss tools 3 in eclipse 3.4.2 and tried to setup some simple seam projects to get familiar with the process.

      I was able to generate some simple CRUD against a mysql server by following the instructions at http://docs.jboss.org/tools/3.0.0.GA/en/seam/html/crud_database_application.html, but I haven't been able to get the same example to work for a sql server 2000 database. When I use 'seam generate entities', it give the error 'couldn't connect to database' when refreshing to select a schema. The Data Source Explorer is able to navigate the the connection correctly, so I'm at a loss for what's causing the problem. I've tried changing the jdbc drivers and connection parameters without luck.

      Is this a problem anyone has run into before, or is there somewhere in eclipse I can look to get more information out of the 'couldn't connection to database' message?

      Thanks for your help!