2 Replies Latest reply on Apr 2, 2009 2:30 AM by Max Rydahl Andersen

    Deployment of JBoss Seam project created by JBoss Tools

    Peter Irmstadt Newbie

      Hi!

      I created a new JBoss Seam EAR project using the newest JBoss Tools and a local running JBoss AS 4.2.3GA under Windows Vista x64.

      Now the project needs to be deployed to a productive system this is the same JBoss AS but running under Debian x32. I wondered there was no trace of the project within the "deploy" folders of my local server. I read in my documentation that this is where projects are being deployed to?!

      I finally found the datasource file and the .ear folder (is this right that it isn't a file called *.ear but a folder?) but only in the directory "c:\my-eclipse-workspace\.metadata\.plugins\org.jboss.ide.eclipse.as.core\JBoss_4.2_Server\deploy\".

      I copied the myProject-ds.xml and the .ear folder in the defaut\deploy folder of my productive server and started it. Even when the application started it behaved strange - the validation messages for example where old ones. Actions that work on my local server doesn't work on the remote one - even when they access the same database - I don't get errors but strange validation messages instead. For example I can't change my password because the application always says that the password is too short and does not match with the "verify password" field - what is actually does.

      -> Might a reason be that I am locally using the "JDK6" version of the AS while the productive server uses the "JDK5" version instead?

      -> How do I "build" that project correctly from JBoss Tools to deploy it to my remote server? (I can't mount that server at the moment, I can only copy files to it).

      Thank you so much in advance!