2 Replies Latest reply on Aug 6, 2009 12:00 PM by William Woodman

    problem with jboss tools m2plugin  and maven warnings about

    William Woodman Master

      downloaded the jboss tools M2 build ontop of gallileo

      ran into problems with maven dependencies and so went off and got some of those to

      currently my jboss tools for maven says 1.0.0.M2-N200907092133-H355

      and my maven for wtp download is build 0.9.9.20090608135


      This kinda starts okay but I get warnings from the maven build checker that my eclipse is not running an JDK build.

      However - i actually do.

      1. I have edited eclipse /preferencves so that i only have jdk 1.6.0.14 running (i deleted the default entry it loaded for me and built the new association)

      2. in my eclipse .ini i have included the following

      -startup
      plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
      --launcher.library
      plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
      -product
      org.eclipse.epp.package.jee.product
      --launcher.XXMaxPermSize
      256M
      -showsplash
      org.eclipse.platform
      --launcher.XXMaxPermSize
      256m
      -vmargs
      -Dosgi.requiredJavaVersion=1.5
      -Xms40m
      -Xmx512m
      -- vm detail
      -vm
       C:\Program Files\Java\jdk1.6.0_14\bin\javaw
      


      3. I have also edited my launucher icon to read as
      C:\eclipse\eclipse\eclipse.exe -vmargs -Xms128m -Xmx512m -vm C:\Program Files\Java\jdk1.6.0_14\bin\javaw -clean
      



      4. and as my {user dir} .m2 dir didnt have a settings.xml i created one of these as follows


      <settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
       http://maven.apache.org/xsd/settings-1.0.0.xsd">
       <localRepository>${user.home}/.m2/repository</localRepository>
       <interactiveMode>true</interactiveMode>
       <usePluginRegistry>false</usePluginRegistry>
       <offline>true</offline>
       <pluginGroups/>
       <servers/>
       <mirrors/>
       <proxies/>
       <profiles>
       <profile>
       <id>test</id>
       <activation>
       <activeByDefault>true</activeByDefault>
       <jdk>(1.5,1.6)</jdk>
       <os>
       <name>Windows XP</name>
       <family>Windows</family>
       <arch>x86</arch>
       <version>5.1.2600</version>
       </os>
       <property>
       <name>mavenVersion</name>
       <value>2.0.3</value>
       </property>
       <file>
       <exists>${basedir}/file2.properties</exists>
       <missing>${basedir}/file1.properties</missing>
       </file>
       </activation>
       </profile>
       </profiles>
       <activeProfiles/>
      </settings>
      
      


      not sure what the maven version should be - included 2.0.3. from an example i saw on google - not sure what version the embedded version is


      This latter got rid of a bunch of errors about a missing settings.xml file -

      however i still get


      27/07/09 17:02:34 BST: Eclipse is running in a JRE, but a JDK is required
      Some Maven plugins may not work when importing projects or updating source folders.


      in my output console - so my question is how do i tell maven that i really want to work with the JDK - cant see why its failing the maven validator test .