1 Reply Latest reply on Aug 19, 2009 2:50 AM by Nick Boldt

    JBoss Richfaces Tools installation issue with Eclipse 3.5

    Christian Kloy Newbie

      Hello,

      I have installed a fresh Eclipse Galileo for JEE on a Windows XP Pro and the JDK 1.6. Now I try to install the RichFaces Tools from the stable update-site and get the following error:

      Cannot complete the install because of a conflicting dependency.
      Software being installed: JBoss Tools RichFaces 3.0.1.GA-R200905070146-H18 (org.jboss.tools.richfaces.feature.feature.group 3.0.1.GA-R200905070146-H18)
      Software currently installed: Eclipse IDE for Java EE Developers 1.2.0.20090621-0820 (epp.package.jee 1.2.0.20090621-0820)
      Only one of the following can be installed at once:
      International Components for Unicode for Java (ICU4J) 4.0.1.v20090415 (com.ibm.icu 4.0.1.v20090415)
      International Components for Unicode for Java (ICU4J) 3.8.1.v20080530 (com.ibm.icu 3.8.1.v20080530)
      Cannot satisfy dependency:
      From: Eclipse IDE for Java EE Developers 1.2.0.20090621-0820 (epp.package.jee 1.2.0.20090621-0820)
      To: org.eclipse.epp.package.jee.feature.feature.group [1.2.0.20090621-0820]
      Cannot satisfy dependency:
      From: Java EE IDE Feature 1.2.0.20090621-0820 (org.eclipse.epp.package.jee.feature.feature.group 1.2.0.20090621-0820)
      To: org.eclipse.platform.feature.group [3.5.0.v20090611a-9gEeG1HFtQcmRThO4O3aR_fqSMvJR2sJ]
      Cannot satisfy dependency:
      From: Eclipse Platform 3.5.0.v20090611a-9gEeG1HFtQcmRThO4O3aR_fqSMvJR2sJ (org.eclipse.platform.feature.group 3.5.0.v20090611a-9gEeG1HFtQcmRThO4O3aR_fqSMvJR2sJ)
      To: org.eclipse.rcp.feature.group [3.5.0.v20090519-9SA0FwxFv6x089WEf-TWh11]
      Cannot satisfy dependency:
      From: Eclipse RCP 3.5.0.v20090519-9SA0FwxFv6x089WEf-TWh11 (org.eclipse.rcp.feature.group 3.5.0.v20090519-9SA0FwxFv6x089WEf-TWh11)
      To: com.ibm.icu [4.0.1.v20090415]
      Cannot satisfy dependency:
      From: SSE JavaScript Source Editor 1.0.200.v200805160650 (org.eclipse.wst.javascript.ui 1.0.200.v200805160650)
      To: bundle com.ibm.icu [3.4.4,4.0.0)
      Cannot satisfy dependency:
      From: Jsp Editor Plug-in 3.0.1.GA-R200905070146-H18 (org.jboss.tools.jst.jsp 3.0.1.GA-R200905070146-H18)
      To: bundle org.eclipse.wst.javascript.ui 0.0.0
      Cannot satisfy dependency:
      From: JBoss Tools RichFaces 3.0.1.GA-R200905070146-H18 (org.jboss.tools.richfaces.feature.feature.group 3.0.1.GA-R200905070146-H18)
      To: org.jboss.tools.jst.jsp [3.0.1.GA-R200905070146-H18]

      It seems that there is one plugin (JavaScript Editor), which depends on ICU4J 3.8.1 and all the other plugins need version 4.0.1.
      Is there a workaround?

      Best Regards
      Christian