4 Replies Latest reply on Nov 6, 2009 3:57 AM by Max Rydahl Andersen

    Please give this back to Hibernate or focus on the hibernate

    Thomas Polliard Newbie

      The hibernate tools used to be difficult to get installed pre JBOSS but when you did get them installed. It worked. Now a days I have to rely on ant scripts to do all the work since the tools almost NEVER work. JBOSS please spend a little more time if your going to own the hibernate tools and eclipse plugin making sure that it works or else give the ownership back to hibernate.

      Case In Point:
      Using Eclipse - Galileo (base J2EE Install)
      Milestone Build of the tools when creating a hbm.xml file (Unhandled event loop exception Java.lan.StackOverflowError)
      Nightly Build of the tools when creating a hbm.xml file (Unhandled event loop exception Java.lan.StackOverflowError)

      Sorry if this seems rude, I'm just tired of having to rely on Ant to do what your toolset is supposed to do for me.

      Before some Fan Boys comment back. Yes I have worked with Ganymede and the tools are just as broken after a base installation there using the "STABLE" tools.

      Thomas

        • 1. Re: Please give this back to Hibernate or focus on the hiber
          Denis Golovin Master

          could you post stack trace here to see what is going on. I could not reproduce it at once, but that doesn't mean there is no issues.

          • 2. Re: Please give this back to Hibernate or focus on the hiber
            Denis Golovin Master

            What is your development scenario? Are you trying enable hibernate for existing Domain Model in java?

            Thanks

            • 3. Re: Please give this back to Hibernate or focus on the hiber
              Vitali Yemialyanchyk Newbie

              hello, Thomas.
              from "some Fan Boys"
              if you didn't know - jira for bug reports is here:
              https://jira.jboss.org/jira/browse/JBIDE
              stacktrace is essential to find/fix the problem.
              If you want to discuss Hibernate Tools functionality use this forum:
              https://forum.hibernate.org/viewforum.php?f=6

              ant scripts, which you are using, use the same code bundle which Hibernate Tools use. In some cases ant scripts better, in other cases - Hibernate Tools. if you prefere ant scripts - it is your choice.

              • 4. Re: Please give this back to Hibernate or focus on the hiber
                Max Rydahl Andersen Master

                 

                "polliard" wrote:
                The hibernate tools used to be difficult to get installed pre JBOSS but when you did get them installed. It worked. Now a days I have to rely on ant scripts to do all the work since the tools almost NEVER work. JBOSS please spend a little more time if your going to own the hibernate tools and eclipse plugin making sure that it works or else give the ownership back to hibernate.


                Sorry you are having troubles but do realize that it is still in the hands of Hibernate, i.e. me ?

                If you got issues then just like everyone had to do in the past you have to report the issues with information about what goes wrong - i.e. the stack traces and what part of hibernate tools you are actually using when generating hbm.xml files ? Is it the code generation or the wizards ?

                The new hbm.xml files wizards have been going through major new features and thus you might see issues if you are using the milestones and nightlies - if you want 100% stable then use the stable releases!

                But please, give some more details and we will fix them.

                i.e. I just tried with M4 and I could not trigger a stackoverflow error - so please give some more details.


                Before some Fan Boys comment back. Yes I have worked with Ganymede and the tools are just as broken after a base installation there using the "STABLE" tools.


                Again, "just as broken" doesn't help neither you or me. What is broken ? I use the tools constantly and sure I know of some issues and I reported them all - but none where stopship issues. If you found some, please take the time to report the issues.

                Note, i've been on vacation for 2 weeks so maybe you already did report them in jira - if yes, then please post the links here.