2 Replies Latest reply on Aug 30, 2004 7:45 AM by Alon Agmon

    wiki test case -fails sample-server-web

    ilays Newbie

      i deployed the wiki samples with no problems
      but when i run the tests i get the following error:

      Testsuite: com.underworld.crimeportal.ClientSideApplTestCase
      Tests run: 2, Failures: 0, Errors: 2, Time elapsed: 2.797 sec
      
      Testcase: testApplClientAccessJSE took 0.437 sec
       Caused an ERROR
      null
      java.lang.reflect.UndeclaredThrowableException
       at $Proxy2.getContactInfo(Unknown Source)
       at com.underworld.crimeportal.ClientSideApplTestCase.testApplClientAccessJSE(ClientSideApplTestCase.java:48)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      Caused by: org.xml.sax.SAXException: SimpleDeserializer encountered a child element, which is NOT expected, in something it was trying to deserialize.
       at org.apache.axis.encoding.ser.SimpleDeserializer.onStartChild(SimpleDeserializer.java:204)
       at org.apache.axis.encoding.DeserializationContextImpl.startElement(DeserializationContextImpl.java:1181)
       at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:244)
       at org.apache.axis.message.SOAPElementAxisImpl.publishToHandler(SOAPElementAxisImpl.java:1409)
       at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:264)
       at org.apache.axis.message.RPCElement.getParams(RPCElement.java:398)
       at org.apache.axis.client.Call.invoke(Call.java:2605)
       at org.apache.axis.client.Call.invoke(Call.java:2487)
       at org.apache.axis.client.Call.invoke(Call.java:1948)
       at org.apache.axis.client.AxisClientProxy.invoke(AxisClientProxy.java:251)
       ... 17 more


      its not the first time i get this error running a doc/lit client .
      could it be a bug?
      or its just my configuration somewhere...