4 Replies Latest reply on Apr 13, 2005 8:28 AM by Thomas Diesler

    war deploying affects WS

    Slava Shelestyuk Newbie

      I have a JAX-RPC WebService based on a SLSB, it's accessed thru the code:
      ServiceFactory serviceFactory = ServiceFactory.newInstance();
      Service service = serviceFactory.createService(
      new URL( "http://localhost:2000/ka/LSService?WSDL" ),
      new QName( "http://webservice.ejb.ka.plesk.com", "LSEndpointService" ));
      LSEndpoint endpoint = (LSEndpoint) service.getPort( LSEndpoint.class );

      while just one jar is deployed everything is ok, but when i also deploy my war i get:
      [java] javax.xml.rpc.ServiceException: Error processing WSDL document:
      [java] java.io.FileNotFoundException: http://localhost:2000/ka/LSService?WSDL
      [java] at org.jboss.axis.client.Service.initService(Service.java:287)
      [java] at org.jboss.axis.client.Service.(Service.java:189)
      [java] at org.jboss.webservice.client.ServiceImpl.(ServiceImpl.java:108)
      [java] at org.jboss.webservice.client.ServiceFactoryImpl.createService(ServiceFactoryImpl.java:111)

      in fact, the last war i tried i specially made as an empty war with just a META-INF/MANIFEST.MF inside, and anyway it breaks WS call from a client.

      jar redeploying solves the problem, but this affects my web,
      i get on my login page at http://localhost:2000/ka:
      And now... Some Services
      * ka.jar#LSEndpoint (wsdl)
      ...

      though the page looked fine before.

      the problem is present on 4.0.0 and the latest 4.0.2RC1.