6 Replies Latest reply on Oct 24, 2005 3:38 PM by dpocock

    <port-uri> migrating to 4.0.1sp1 <port-component-uri>

    Andre Simon Newbie

      Hi there

      I mirgrate my JBossWS EJBs from 4.0.0 to 4.0.1sp1.
      I changed the <port-uri> Tag in the jboss.xml descriptor
      to <port-component-uri>, during the deployment I´ve got this Exception:


      14:03:55,765 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
      Incompletely deployed packages:
      org.jboss.deployment.DeploymentInfo@57057a15 { url=file:/C:/jboss-4.0.1sp1/server/default/deploy/my.ear }
       deployer: org.jboss.deployment.EARDeployer@ce3b62
       status: Deployment FAILED reason: Error in jboss.xml for Bean myEJB: Expected at least two tokens <port-component-uri>
       state: FAILED
       watch: file:/C:/jboss-4.0.1sp1/server/default/deploy/gv.ear
       altDD: null
       lastDeployed: 1113912234703
       lastModified: 1113912233734
       mbeans:
      


      Seems like the XML parser needs at least two <port-component-uri> Tags, but this make no sense, and if I give him these two tags the parser throws the exception that he want only one <port-component-uri>, what seems right if he validate against the jboss_4_0.dtd.

      my jboss.xml code

       <session>
       .
       .
       .
       <port-component>
       <port-component-name>myPort</port-component-name>
       <port-uri>/myPortURI</port-uri>
       <auth-method>BASIC</auth-method>
       </port-component>
       </session>
      


      Has anybody an idea or a hint what´s wrong?

      dre

        • 1. Re: <port-uri> migrating to 4.0.1sp1 <port-component-uri>
          Andre Simon Newbie

          my jboss.xml code before was the old for JBoss 4.0.0
          the exception is caught by this jboss.xml during deployment on
          Jboss 4.0.1sp1


          .
          .
          .
          <port-component>
          <port-component-name>myPort</port-component-name>
          <port-component-uri>/myPortURI</port-component-uri>
          <auth-method>BASIC</auth-method>
          </port-component>


          thanks for every helpfull hint:

          dre

          • 2. Re: <port-uri> migrating to 4.0.1sp1 <port-component-uri>
            Jason Greene Master

            port-uri used the deployment jar name to build the final uri.

            port-component-uri uses the context/port to build the uri.

            So in your case you would want the value to be:

            /my-context-that-i-want/myPortURI

            -Jason

            • 3. Re: <port-uri> migrating to 4.0.1sp1 <port-component-uri>
              Andre Simon Newbie

              Thanks Jason this works,

              but now my wsdl files are in the context directory
              /my-context-that-i-want and these wsdl files have
              a security-constraint. This is good because my servicedescription
              is now protected, but if myself cant access them is this problematic.

              I tried it via simple HTTP Authentification:

              name:pwd@my-context-that-i-want/myService?wsdl
              

              it doesnt work, probably the password is digested?,
              but the Realm <auth-meth> is BASIC.

              somewhere in this forum, I saw that there exists an jboss Class
              extending ServiceFactory with new createService Methods, but I want use only the jaxrpc api classes.

              Are there soloutions?

              greetings to the men from the Snoqulamie Pass,
              I wanna be there to.

              • 4. Re: <port-uri> migrating to 4.0.1sp1 <port-component-uri>
                Jason Greene Master

                It does use basic auth. The name:pwd@url doesn't care what the auth method is, it is nearly identical to filling in the values in the pop-up. If you password has a non url friendly character in it, then this will cause problems.

                By the way, the underlying security mechanism is being handled by tomcat, so there is nothing special here. You may want to check your security domain configuration and make sure it is set up correctly. Also look in the logs and see if there is a security exception.

                -Jason

                • 5. Re: <port-uri> migrating to 4.0.1sp1 <port-component-uri>
                  Andre Simon Newbie

                  The Http Authentification works on IE Auth-PopUp and on Firefox via URL input and the Auth-PopUp.

                  If I try it via
                  javax.rpc.ServiceFactory.createService(URL url, QName qname),
                  this Exception was thrown on clientside:

                  Caused by: javax.xml.rpc.ServiceException: Modellfehler: Analyse des Dokuments bei "http://name:pwd@localhost:8080/myContext/myService?wsdl" fehlgeschlagen: java.io.IOException: Server returned HTTP response code: 401 for URL: http://name:pwd@localhost:8080/myContext/myService?wsdl
                  at com.sun.xml.rpc.client.dii.ConfiguredService.(ConfiguredService.java:64)
                  at com.sun.xml.rpc.client.dii.ConfiguredService.(ConfiguredService.java:48)
                  at com.sun.xml.rpc.client.ServiceFactoryImpl.createService(ServiceFactoryImpl.java:41)
                  


                  by the way there where no non url friendly characters in the URL, but for this case I encode the name and the pwd with java.net.URLEncoder

                  the Serverlog says nothing.

                  if I copy the URL from this Exception and put it in firefox my wsdlfile opened and the Serverlog told me stories whats on the ServiceEndpointServletEJB.

                  • 6. Re: <port-uri> migrating to 4.0.1sp1 <port-component-uri>
                    dpocock Newbie


                    I'm having this problem too - it is a client side issue in ServiceFactory.createService

                    I put the username and password in the URL object.

                    This worked with Axis, so why doesn't it work with the JBoss client code?